summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-11-11 17:26:52 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-11-11 20:50:17 +0100
commitb3168dc4daa93676caa1a84c07cbb4aa16a382e5 (patch)
treee55b767869ad3ab1b0756b85186f9dcecc0b0766 /dev-qt/qtlocation
parentgui-wm/gamescope: Bump to 3.13.0, drop old 3.12.7 (diff)
downloadgentoo-b3168dc4daa93676caa1a84c07cbb4aa16a382e5.tar.gz
gentoo-b3168dc4daa93676caa1a84c07cbb4aa16a382e5.tar.bz2
gentoo-b3168dc4daa93676caa1a84c07cbb4aa16a382e5.zip
dev-qt/qtlocation: Fix HereMap plugin not supporting auth via apiKey
QTBUG: https://bugreports.qt.io/browse/QTBUG-118447 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtlocation')
-rw-r--r--dev-qt/qtlocation/Manifest1
-rw-r--r--dev-qt/qtlocation/qtlocation-5.15.11-r1.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-qt/qtlocation/Manifest b/dev-qt/qtlocation/Manifest
index fe7340d4467d..15c5e2f5fd20 100644
--- a/dev-qt/qtlocation/Manifest
+++ b/dev-qt/qtlocation/Manifest
@@ -1,4 +1,5 @@
DIST qtlocation-5.15.11-fix-appendChildNode.patch.xz 536 BLAKE2B f20566fb1b28cbb6784a270e9687153166779fe70d048dc947a705bb77126c7420b6f714c3135770708a2a0e1b65da385ef3d893f94307f99fa3b39b8abb2b6e SHA512 3a72c142150f65630a209a6d5ca36f796eeb57addae390dc1ae87ecf9d27d07a3a8c799bc4729a3030680bf032a245622037bcba7abaceaf3d1b98091b1eb66b
+DIST qtlocation-5.15.11-patchset.tar.xz 4796 BLAKE2B dcfa75bd3fb2e9069e1a530c27e2b4e9ac921fcf0ccb712f0894375b575ba25103948c6e5b85b56a8f9c9f2d7edf7df8e38501e93356e69f060b577a04c2d221 SHA512 14bd2864abc6f446dc4fbac03548cb42305685b46db757d856360780144095a021130bc0ebf1d07a516dc7991dc0cfbf733bd0ef6be58237bc15822c21af1d0b
DIST qtlocation-everywhere-opensource-src-5.15.11.tar.xz 6554216 BLAKE2B e882ecdc4f565f48874371e5235dc96769fbded9446a2a7f1afd869217f4bc75a9f42c6c34627311b55fbfc60da9a95fc7472c3ced83fca722799497b437a9d9 SHA512 d439d03ff9044fc70165d1ceb5def9ec3290beec56b3e893409a24cd355651a4317e0eadff0266d38203ff84429a5fb8659a200f094669716579b6791a1a0f6d
DIST qtlocation-everywhere-src-6.5.2.tar.xz 3032488 BLAKE2B c8cd34980b0f78326fb70bf76a04094cf3e27afbd6aed6d982ce30abfa9dc4250d164dbe11c1027bedcdeee3b7c907c3716e88f16eeae173b846ccdf2c38d458 SHA512 b1e5c1813deb8a4eb9f8548afa935f1a2145ed3168f0276493ea501057fd4f70b8980ae387248a59e50f0e450ae245a04cd8636fb61d37af9c3634ff1cdd24f3
DIST qtlocation-everywhere-src-6.5.3.tar.xz 3032844 BLAKE2B 3b23b8d1b1a06476428879c0d32d3fc21119e50410d97ee3948c0ab7b22832f27f1e5ed2d06e62f53baf668b77630a27e5c6814b54c2e9498706a436256c4005 SHA512 6633dedba335b8de4c96f98f4709a147e225e82fee1ed741938e15e1540421ad7c3140baec75914f0844a793433abcadaf3ce72d944662b62778327d65ff7348
diff --git a/dev-qt/qtlocation/qtlocation-5.15.11-r1.ebuild b/dev-qt/qtlocation/qtlocation-5.15.11-r1.ebuild
new file mode 100644
index 000000000000..2b566c3af445
--- /dev/null
+++ b/dev-qt/qtlocation/qtlocation-5.15.11-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PATCHSET="${P}-patchset"
+inherit qt5-build
+
+DESCRIPTION="Location (places, maps, navigation) library for the Qt5 framework"
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+ MAPBOXGL_COMMIT=4c88f2c0e61daa89f584a8a9a3eba210221c6920
+ SRC_URI+=" https://invent.kde.org/qt/qt/${PN}-mapboxgl/-/archive/${MAPBOXGL_COMMIT}/${PN}-mapboxgl-${MAPBOXGL_COMMIT}.tar.gz -> ${PN}-mapboxgl-${PV}-${MAPBOXGL_COMMIT:0:8}.tar.gz
+ https://dev.gentoo.org/~asturm/distfiles/${PATCHSET}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+RDEPEND="
+ dev-libs/icu:=
+ =dev-qt/qtcore-${QT5_PV}*
+ =dev-qt/qtdeclarative-${QT5_PV}*
+ =dev-qt/qtgui-${QT5_PV}*
+ =dev-qt/qtnetwork-${QT5_PV}*
+ =dev-qt/qtpositioning-${QT5_PV}*[qml]
+ =dev-qt/qtsql-${QT5_PV}*
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+ =dev-qt/qtconcurrent-${QT5_PV}*
+"
+
+QT5_TARGET_SUBDIRS=(
+ src/3rdparty/clipper
+ src/3rdparty/poly2tri
+ src/3rdparty/clip2tri
+ src/3rdparty/mapbox-gl-native
+ src/location
+ src/imports/location
+ src/imports/locationlabs
+ src/plugins/geoservices
+)
+
+if [[ ${QT5_BUILD_TYPE} == release ]]; then
+
+PATCHES=( "${WORKDIR}/${PATCHSET}" )
+
+src_prepare() {
+ rm -rf src/3rdparty/mapbox-gl-native/* || die
+ mv "${WORKDIR}"/${PN}-mapboxgl-${MAPBOXGL_COMMIT}/* src/3rdparty/mapbox-gl-native || die
+ qt5-build_src_prepare
+}
+fi
+
+src_configure() {
+ # src/plugins/geoservices requires files that are only generated when
+ # qmake is run in the root directory. Bug 633776.
+ qt5_configure_oos_quirk qtlocation-config.pri src/location
+ qt5-build_src_configure
+}