summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2015-10-30 04:05:51 +1100
committerMichael Palimaka <kensington@gentoo.org>2015-11-01 01:29:09 +1100
commit2f38ee0ac7e073edbf0018b93b78e035081ff595 (patch)
treebe0dec6066b33a2d21f925858d4ec8626c9f7d0d /dev-qt/qtphonon
parentdev-python/autopep8: Add python3.5 support (diff)
downloadgentoo-2f38ee0ac7e073edbf0018b93b78e035081ff595.tar.gz
gentoo-2f38ee0ac7e073edbf0018b93b78e035081ff595.tar.bz2
gentoo-2f38ee0ac7e073edbf0018b93b78e035081ff595.zip
dev-qt: remove 4.8.5
Diffstat (limited to 'dev-qt/qtphonon')
-rw-r--r--dev-qt/qtphonon/qtphonon-4.8.5.ebuild54
1 files changed, 0 insertions, 54 deletions
diff --git a/dev-qt/qtphonon/qtphonon-4.8.5.ebuild b/dev-qt/qtphonon/qtphonon-4.8.5.ebuild
deleted file mode 100644
index b70091fdfdf9..000000000000
--- a/dev-qt/qtphonon/qtphonon-4.8.5.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=4
-
-inherit qt4-build
-
-DESCRIPTION="The Phonon module for the Qt toolkit"
-SLOT="4"
-if [[ ${QT4_BUILD_TYPE} == live ]]; then
- KEYWORDS=""
-else
- KEYWORDS="amd64 arm hppa ~ia64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-fi
-IUSE="dbus qt3support"
-
-DEPEND="
- ~dev-qt/qtgui-${PV}[aqua=,debug=,qt3support=]
- !kde-apps/phonon-kde
- !kde-base/phonon-xine
- !media-libs/phonon
- !media-sound/phonon
- !aqua? ( media-libs/gstreamer:0.10
- media-plugins/gst-plugins-meta:0.10 )
- aqua? ( ~dev-qt/qtopengl-${PV}[aqua=,debug=,qt3support=] )
- dbus? ( ~dev-qt/qtdbus-${PV}[aqua=,debug=] )
-"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- QT4_TARGET_DIRECTORIES="
- src/phonon
- src/plugins/phonon"
-
- QT4_EXTRACT_DIRECTORIES="
- include
- src"
-
- QCONFIG_ADD="phonon"
- QCONFIG_DEFINE="QT_PHONON
- $(use !aqua && echo QT_GSTREAMER)"
-
- qt4-build_pkg_setup
-}
-
-src_configure() {
- myconf+="
- -phonon -phonon-backend -no-opengl -no-svg
- $(qt_use dbus qdbus)
- $(qt_use qt3support)"
-
- qt4-build_src_configure
-}