summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-02-26 21:37:41 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-02-26 22:56:43 +0100
commit1c95aab1a62e2d11ec6a728204bd3d819bc9a4b2 (patch)
tree5080379dd64cb93bd2530a9eff3c4eb6e63953a5 /dev-qt/qtwayland
parentdev-qt/qtwayland: Fix USE libinput (diff)
downloadgentoo-1c95aab1a62e2d11ec6a728204bd3d819bc9a4b2.tar.gz
gentoo-1c95aab1a62e2d11ec6a728204bd3d819bc9a4b2.tar.bz2
gentoo-1c95aab1a62e2d11ec6a728204bd3d819bc9a4b2.zip
dev-qt/qtwayland: Add USE vulkan
Closes: https://bugs.gentoo.org/703594 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-qt/qtwayland')
-rw-r--r--dev-qt/qtwayland/metadata.xml1
-rw-r--r--dev-qt/qtwayland/qtwayland-5.14.1-r1.ebuild9
2 files changed, 8 insertions, 2 deletions
diff --git a/dev-qt/qtwayland/metadata.xml b/dev-qt/qtwayland/metadata.xml
index 4fb03e679017..db7a41ae479b 100644
--- a/dev-qt/qtwayland/metadata.xml
+++ b/dev-qt/qtwayland/metadata.xml
@@ -7,6 +7,7 @@
</maintainer>
<use>
<flag name="libinput">Enable support for input devices via <pkg>dev-libs/libinput</pkg></flag>
+ <flag name="vulkan">Enable support for Vulkan-based server buffer integration</flag>
</use>
<upstream>
<bugs-to>https://bugreports.qt.io/</bugs-to>
diff --git a/dev-qt/qtwayland/qtwayland-5.14.1-r1.ebuild b/dev-qt/qtwayland/qtwayland-5.14.1-r1.ebuild
index 0602db2ff595..5fa75b673a70 100644
--- a/dev-qt/qtwayland/qtwayland-5.14.1-r1.ebuild
+++ b/dev-qt/qtwayland/qtwayland-5.14.1-r1.ebuild
@@ -10,15 +10,16 @@ if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
fi
-IUSE="+libinput xcomposite"
+IUSE="+libinput vulkan xcomposite"
DEPEND="
>=dev-libs/wayland-1.6.0
~dev-qt/qtcore-${PV}
~dev-qt/qtdeclarative-${PV}
- ~dev-qt/qtgui-${PV}[egl,libinput=]
+ ~dev-qt/qtgui-${PV}[egl,libinput=,vulkan=]
media-libs/mesa[egl]
>=x11-libs/libxkbcommon-0.2.0
+ vulkan? ( dev-util/vulkan-headers )
xcomposite? (
x11-libs/libX11
x11-libs/libXcomposite
@@ -37,6 +38,10 @@ src_prepare() {
src/plugins/shellintegration/xdg-shell-v6/xdg-shell-v6.pro \
tests/auto/compositor/compositor/compositor.pro
+ qt_use_disable_config vulkan wayland-vulkan-server-buffer \
+ src/plugins/hardwareintegration/client/client.pro \
+ src/plugins/hardwareintegration/compositor/compositor.pro
+
use xcomposite || rm -r config.tests/xcomposite || die
qt5-build_src_prepare