summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-01-26 16:50:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2021-01-26 16:56:09 +0100
commit1d67de359b5a287f62418889fe5873e9a393f953 (patch)
tree924772ea6bb7e2dfd92ac195bba8f668c515a2c5 /dev-ros/ament_lint/ament_lint-0.10.1.ebuild
parentdev-ros/ament_cmake_copyright: bump to 0.10.1 (diff)
downloadgentoo-1d67de359b5a287f62418889fe5873e9a393f953.tar.gz
gentoo-1d67de359b5a287f62418889fe5873e9a393f953.tar.bz2
gentoo-1d67de359b5a287f62418889fe5873e9a393f953.zip
dev-ros/ament_lint: bump to 0.10.1
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/ament_lint/ament_lint-0.10.1.ebuild')
-rw-r--r--dev-ros/ament_lint/ament_lint-0.10.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ros/ament_lint/ament_lint-0.10.1.ebuild b/dev-ros/ament_lint/ament_lint-0.10.1.ebuild
new file mode 100644
index 000000000000..7d09ac309c69
--- /dev/null
+++ b/dev-ros/ament_lint/ament_lint-0.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+
+inherit distutils-r1
+
+ROS_PN="ament_lint"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/ament/ament_lint"
+ SRC_URI=""
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+ S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+fi
+
+DESCRIPTION="Common API for ament linter packages"
+HOMEPAGE="https://github.com/ament/ament_lint"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+else
+ KEYWORDS="~amd64"
+fi
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+BDEPEND=""