summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-05-18 17:33:28 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-05-18 18:34:58 +0200
commitc6e8a5cdf68eb5c66693c88e6ed02c040b2d5883 (patch)
treea1d1551f5181e11ee8da7fa15f83f848696ffac7 /dev-ros/genpy/genpy-0.6.11.ebuild
parentmedia-tv/kodi: Set KODI_HOME when running tests (diff)
downloadgentoo-c6e8a5cdf68eb5c66693c88e6ed02c040b2d5883.tar.gz
gentoo-c6e8a5cdf68eb5c66693c88e6ed02c040b2d5883.tar.bz2
gentoo-c6e8a5cdf68eb5c66693c88e6ed02c040b2d5883.zip
dev-ros/genpy: bump to 0.6.11
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/genpy/genpy-0.6.11.ebuild')
-rw-r--r--dev-ros/genpy/genpy-0.6.11.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-ros/genpy/genpy-0.6.11.ebuild b/dev-ros/genpy/genpy-0.6.11.ebuild
new file mode 100644
index 000000000000..29c86a165741
--- /dev/null
+++ b/dev-ros/genpy/genpy-0.6.11.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/genpy"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Python ROS message and service generators"
+HOMEPAGE="http://wiki.ros.org/genpy"
+LICENSE="BSD"
+SLOT="0/${PV}"
+IUSE=""
+
+RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+PATCHES=( "${FILESDIR}/yaml.patch" )