summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 14:19:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 16:34:21 +0200
commit13a0ae8f6f4fedc8fe5efd443c015d419abbf8e4 (patch)
treefd6f17576f57de05191012ced9cc51e4dbcf76a7 /dev-ros/monocam_settler/monocam_settler-9999.ebuild
parentdev-ros/settlerlib: Add missing gtest dep for tests (diff)
downloadgentoo-13a0ae8f6f4fedc8fe5efd443c015d419abbf8e4.tar.gz
gentoo-13a0ae8f6f4fedc8fe5efd443c015d419abbf8e4.tar.bz2
gentoo-13a0ae8f6f4fedc8fe5efd443c015d419abbf8e4.zip
dev-ros/monocam_settler: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/monocam_settler/monocam_settler-9999.ebuild')
-rw-r--r--dev-ros/monocam_settler/monocam_settler-9999.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ros/monocam_settler/monocam_settler-9999.ebuild b/dev-ros/monocam_settler/monocam_settler-9999.ebuild
new file mode 100644
index 000000000000..b413582608f7
--- /dev/null
+++ b/dev-ros/monocam_settler/monocam_settler-9999.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-perception/calibration"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/actionlib_msgs dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Listens on a ImageFeatures topic, and waits for the data to settle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/actionlib[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/roscpp_serialization
+ dev-ros/settlerlib
+ dev-libs/boost:=[threads]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"