summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:21:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a (patch)
treebea2043a0d6259113cc902be38627aab1cfea323 /dev-ros/navfn/navfn-9999.ebuild
parentdev-ros/nav_core: Initial import. Ebuild by me. (diff)
downloadgentoo-8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a.tar.gz
gentoo-8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a.tar.bz2
gentoo-8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a.zip
dev-ros/navfn: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
Diffstat (limited to 'dev-ros/navfn/navfn-9999.ebuild')
-rw-r--r--dev-ros/navfn/navfn-9999.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ros/navfn/navfn-9999.ebuild b/dev-ros/navfn/navfn-9999.ebuild
new file mode 100644
index 000000000000..bea902da7af6
--- /dev/null
+++ b/dev-ros/navfn/navfn-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/visualization_msgs
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ x11-libs/fltk
+ media-libs/netpbm
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+ dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" )