summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-10-11 17:34:05 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-10-11 17:34:05 +0200
commit620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14 (patch)
tree0ab51e3ab9e59b2d2c3ca33a5894ed9ae5102ab7 /dev-ros/octomap_ros/octomap_ros-9999.ebuild
parentros-meta/rosbridge_suite: Initial import. Ebuild by me. (diff)
downloadgentoo-620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14.tar.gz
gentoo-620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14.tar.bz2
gentoo-620a2a96ea7a45aa4a3ba239b4d6c6cab81e9d14.zip
dev-ros/octomap_ros: Initial import. Ebuild by me.
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-ros/octomap_ros/octomap_ros-9999.ebuild')
-rw-r--r--dev-ros/octomap_ros/octomap_ros-9999.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-ros/octomap_ros/octomap_ros-9999.ebuild b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
new file mode 100644
index 000000000000..36b7f89cdac5
--- /dev/null
+++ b/dev-ros/octomap_ros/octomap_ros-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/OctoMap/octomap_ros"
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="Conversion functions between ROS / PCL and OctoMap's native types"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/tf
+ dev-ros/pcl_ros
+ dev-ros/octomap_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"