summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 14:18:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:15 +0200
commit5167b681388af5ebcd8ef8d92353d4061ca828b5 (patch)
treed841354b2e8aa4b1f7f995b655b92ea70fd0dbe7 /dev-ros/pluginlib
parentdev-ros/pointcloud_to_laserscan: Remove old (diff)
downloadgentoo-5167b681388af5ebcd8ef8d92353d4061ca828b5.tar.gz
gentoo-5167b681388af5ebcd8ef8d92353d4061ca828b5.tar.bz2
gentoo-5167b681388af5ebcd8ef8d92353d4061ca828b5.zip
dev-ros/pluginlib: bump to 1.13.0
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/pluginlib')
-rw-r--r--dev-ros/pluginlib/Manifest1
-rw-r--r--dev-ros/pluginlib/pluginlib-1.13.0.ebuild27
-rw-r--r--dev-ros/pluginlib/pluginlib-9999.ebuild4
3 files changed, 30 insertions, 2 deletions
diff --git a/dev-ros/pluginlib/Manifest b/dev-ros/pluginlib/Manifest
index 3d7ee7a419eb..ba4ddd6103ec 100644
--- a/dev-ros/pluginlib/Manifest
+++ b/dev-ros/pluginlib/Manifest
@@ -1,2 +1,3 @@
DIST pluginlib-1.12.0.tar.gz 20298 BLAKE2B 9d6e5adb6bd64f02d237fa1992402cb016266071c0fa0447709880f90550f36f9e280163a3e054594235d0102f7fb22f4b98a56216b0db9ebaa200b99d018570 SHA512 fcd51908c6c7223bbe50eb43733ba6d00e11419b26d2b9a05aaaf6498020fcd44bacc19313c3a4dd7524bf69d4f54aec27e05b1f88ee578191484c53c1e3f767
DIST pluginlib-1.12.1.tar.gz 19619 BLAKE2B e91fb15b4857fae10012a71df606f5040d5a62bdee596695c873808790eea02cd380eedda6c438388264003d7ac930ebc2c649a421411580dd095365c93d3c8e SHA512 1a15cd934c4f93fecf32d7d3cab1ee6caae61d59aa65d1f796ab2ba63d5204a6fe28744c28eac80d304bd802b184afe79ead621b3c370c6d3526a944c144d724
+DIST pluginlib-1.13.0.tar.gz 20124 BLAKE2B d2c2c643345e3b76bc580e413538af3ddb49ffe00d9d14ee6ad4dfb3d930ca70bad12ef232c831474238050f4b934c0ca5accded800b8c719c006c01e3c7ac00 SHA512 69566fad8aad92cf1d481117e5beb46c6033538ea08db0487e10766c40e89510d6a58e817f52c0bdce2946813272f2f2e72145e949647e24465f1e13995cf85f
diff --git a/dev-ros/pluginlib/pluginlib-1.13.0.ebuild b/dev-ros/pluginlib/pluginlib-1.13.0.ebuild
new file mode 100644
index 000000000000..e21d6c7ad77a
--- /dev/null
+++ b/dev-ros/pluginlib/pluginlib-1.13.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/pluginlib"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR="${PN}"
+
+inherit ros-catkin
+
+DESCRIPTION="Tools for writing and dynamically loading plugins using the ROS infrastructure"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ >=dev-ros/class_loader-0.3.5:=
+ dev-ros/rosconsole
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-libs/boost:=
+ dev-libs/tinyxml2:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )"
+PATCHES=( "${FILESDIR}/catkin_prefix_path2.patch" )
diff --git a/dev-ros/pluginlib/pluginlib-9999.ebuild b/dev-ros/pluginlib/pluginlib-9999.ebuild
index 8b802f6e3618..e21d6c7ad77a 100644
--- a/dev-ros/pluginlib/pluginlib-9999.ebuild
+++ b/dev-ros/pluginlib/pluginlib-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros/pluginlib"
KEYWORDS="~amd64 ~arm"
@@ -10,7 +10,7 @@ ROS_SUBDIR="${PN}"
inherit ros-catkin
-DESCRIPTION="Provides tools for writing and dynamically loading plugins using the ROS build infrastructure"
+DESCRIPTION="Tools for writing and dynamically loading plugins using the ROS infrastructure"
LICENSE="BSD"
SLOT="0"
IUSE=""