summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-29 12:29:03 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-29 14:20:53 +0200
commit805731f216d7f70f1d8af8079633b62d9a7ea75c (patch)
treeca5f17f21171217f49f9546030bb56430a923592 /dev-ros/rosgraph/rosgraph-1.15.8.ebuild
parentdev-ros/rosbag_storage: Bump to 1.15.8. (diff)
downloadgentoo-805731f216d7f70f1d8af8079633b62d9a7ea75c.tar.gz
gentoo-805731f216d7f70f1d8af8079633b62d9a7ea75c.tar.bz2
gentoo-805731f216d7f70f1d8af8079633b62d9a7ea75c.zip
dev-ros/rosgraph: Bump to 1.15.8.
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rosgraph/rosgraph-1.15.8.ebuild')
-rw-r--r--dev-ros/rosgraph/rosgraph-1.15.8.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-ros/rosgraph/rosgraph-1.15.8.ebuild b/dev-ros/rosgraph/rosgraph-1.15.8.ebuild
new file mode 100644
index 000000000000..0266daff9c69
--- /dev/null
+++ b/dev-ros/rosgraph/rosgraph-1.15.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ROS_REPO_URI="https://github.com/ros/ros_comm"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=tools/${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Prints information about the ROS Computation Graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ $(python_gen_cond_dep "dev-python/netifaces[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/rospkg[\${PYTHON_USEDEP}]")
+"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep "dev-python/mock[\${PYTHON_USEDEP}]")
+ $(python_gen_cond_dep "dev-python/nose[\${PYTHON_USEDEP}]")
+ )"