summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:12:34 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:46 +0200
commit0049464022c1203d41a3960b4401503de0fda620 (patch)
tree37ce05fbe2f17f5ef08d0ff0fa7c6b571ba998d0 /dev-ros/rqt_graph
parentdev-ros/rqt_launch: Remove old (diff)
downloadgentoo-0049464022c1203d41a3960b4401503de0fda620.tar.gz
gentoo-0049464022c1203d41a3960b4401503de0fda620.tar.bz2
gentoo-0049464022c1203d41a3960b4401503de0fda620.zip
dev-ros/rqt_graph: bump to 0.4.14
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/rqt_graph')
-rw-r--r--dev-ros/rqt_graph/Manifest1
-rw-r--r--dev-ros/rqt_graph/rqt_graph-0.4.14.ebuild29
-rw-r--r--dev-ros/rqt_graph/rqt_graph-9999.ebuild5
3 files changed, 32 insertions, 3 deletions
diff --git a/dev-ros/rqt_graph/Manifest b/dev-ros/rqt_graph/Manifest
index 3cba949e37b0..86d4568aa78e 100644
--- a/dev-ros/rqt_graph/Manifest
+++ b/dev-ros/rqt_graph/Manifest
@@ -1,2 +1,3 @@
DIST rqt_graph-0.4.10.tar.gz 18455 BLAKE2B 930f2c7bc5d1797eae06e9d37e9f1268a503ddda3bf28adda47779b5879d578353e77e773e7c4417e670870effa6c6a39b5844f19bb101ba6f3733604514e704 SHA512 a37483ed15dc1f1d1492e53d26252a3db6771a1ecf47469a33314c9d17aef88d2e68a5acdca24e412e1d2409c31311ea2f2983aa54b6a5e3b5de5c11b6ab1191
+DIST rqt_graph-0.4.14.tar.gz 19068 BLAKE2B c03431d4b72b31a913ea427e6988e0de60ac41384ea0ccdc20d07232230db441398ee93f00017dffa70dc7413e847a9f128a2514d7af9a20e3b79d6b73b89231 SHA512 15871a7b48f4e121d5ed3445bbeb2f051218455c08180aeff24a756e6ee8ede795627a60152472fccbea08bd75adfc78f014c16dc9f108db1c3e0824dc630003
DIST rqt_graph-0.4.9.tar.gz 15857 BLAKE2B 52201faed0ec636dc15a7a7067d19d29f72dca4e98412614a24d6e5f38d916f6cf194fa2b11f84ed0d9476a53f0ad3fdcff807b851286f192c5ee1332033d997 SHA512 21d1395f272f38bb27f7549c865a9e2b4ac5d9267c50dbbaf02016b509b6fab08526c35a87f500788bad094e605d89f925baf939742e78f37d615fedcb04776e
diff --git a/dev-ros/rqt_graph/rqt_graph-0.4.14.ebuild b/dev-ros/rqt_graph/rqt_graph-0.4.14.ebuild
new file mode 100644
index 000000000000..d578fd72d82a
--- /dev/null
+++ b/dev-ros/rqt_graph/rqt_graph-0.4.14.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS computation graph"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rosgraph_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+ dev-ros/rosnode[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosservice[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/rqt_graph/rqt_graph-9999.ebuild b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
index 1f2bff4c39fc..d578fd72d82a 100644
--- a/dev-ros/rqt_graph/rqt_graph-9999.ebuild
+++ b/dev-ros/rqt_graph/rqt_graph-9999.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
KEYWORDS="~amd64"
ROS_REPO_URI="https://github.com/ros-visualization/rqt_graph"
-PYTHON_COMPAT=( python2_7 )
inherit ros-catkin