summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-23 12:22:47 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-23 12:22:47 +0200
commita1a044a43562bc7b862e8f654aed76600e185e5a (patch)
treed20b2cb3e6976cea6e31371057b57d8c7df030c6 /dev-ros/rqt_plot/rqt_plot-9999.ebuild
parentdev-ros/rqt_logger_level: Initial import. Ebuild by me. (diff)
downloadgentoo-a1a044a43562bc7b862e8f654aed76600e185e5a.tar.gz
gentoo-a1a044a43562bc7b862e8f654aed76600e185e5a.tar.bz2
gentoo-a1a044a43562bc7b862e8f654aed76600e185e5a.zip
dev-ros/rqt_plot: Initial import. Ebuild by me.
Package-Manager: portage-2.2.21
Diffstat (limited to 'dev-ros/rqt_plot/rqt_plot-9999.ebuild')
-rw-r--r--dev-ros/rqt_plot/rqt_plot-9999.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_plot/rqt_plot-9999.ebuild b/dev-ros/rqt_plot/rqt_plot-9999.ebuild
new file mode 100644
index 000000000000..277ef2440bfe
--- /dev/null
+++ b/dev-ros/rqt_plot/rqt_plot-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_common_plugins"
+PYTHON_COMPAT=( python2_7 )
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin visualizing numeric values in a 2D plot"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ || ( dev-python/matplotlib[${PYTHON_USEDEP}] dev-python/pyqwt:5[${PYTHON_USEDEP}] )
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_gui_py_common[${PYTHON_USEDEP}]
+ dev-ros/rosgraph[${PYTHON_USEDEP}]
+ dev-ros/rostopic[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/rqt_py_common[${PYTHON_USEDEP}]
+ dev-ros/roslib[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"