summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2021-04-02 13:08:52 +0200
committerAlexis Ballier <aballier@gentoo.org>2021-04-05 11:52:07 +0200
commitc79df6af4bd244e6f558dbbff59d1d1ac5a1ee31 (patch)
treec218ffd690c33fbe6e55733f6a4a536b58c7421f /dev-ros/timestamp_tools
parentdev-ros/timestamp_tools: remove merged patch (diff)
downloadgentoo-c79df6af4bd244e6f558dbbff59d1d1ac5a1ee31.tar.gz
gentoo-c79df6af4bd244e6f558dbbff59d1d1ac5a1ee31.tar.bz2
gentoo-c79df6af4bd244e6f558dbbff59d1d1ac5a1ee31.zip
dev-ros/timestamp_tools: Remove old
Package-Manager: Portage-3.0.16, Repoman-3.0.2 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ros/timestamp_tools')
-rw-r--r--dev-ros/timestamp_tools/Manifest1
-rw-r--r--dev-ros/timestamp_tools/files/boost.patch13
-rw-r--r--dev-ros/timestamp_tools/files/tests.patch14
-rw-r--r--dev-ros/timestamp_tools/timestamp_tools-1.6.8-r1.ebuild22
4 files changed, 0 insertions, 50 deletions
diff --git a/dev-ros/timestamp_tools/Manifest b/dev-ros/timestamp_tools/Manifest
index 3c2c50627dce..39c809f5a277 100644
--- a/dev-ros/timestamp_tools/Manifest
+++ b/dev-ros/timestamp_tools/Manifest
@@ -1,2 +1 @@
-DIST driver_common-1.6.8.tar.gz 15055 BLAKE2B 2d9a4c23d65b8e2f60343f5e3b454e1cc41334d34e0246891b533f216acb743df628d95dd2c0087b06284a85e0ea872baad495a7ed7b59c03e8f8ff32eba4ed8 SHA512 b698143d08785088ac13e62f5b96676bd590a84e4ffb147fa3698be6a8ded510f648d043ecdc1d31ba7b95fb3041d06ee1a39b224c359b8612adebdba259d188
DIST driver_common-1.6.9.tar.gz 15374 BLAKE2B 88bcba03596d9a641091d37db8329807cfa0d4dd766298a25f8e41b6da567eb246fdd8c4c8a39698b60a47a118b81b15c3ac93154490a1258d93d3e2fbd5c049 SHA512 1a5f7d261a3e754b380824256d35432cee521b7d255a7f152b6a69d5181ea45a2bbca7a7c6d4e0bea753c8f3c59018a63357c87d2535a9cb55ba311f11e5d749
diff --git a/dev-ros/timestamp_tools/files/boost.patch b/dev-ros/timestamp_tools/files/boost.patch
deleted file mode 100644
index de7878ca19b8..000000000000
--- a/dev-ros/timestamp_tools/files/boost.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Index: timestamp_tools/include/timestamp_tools/trigger_matcher.h
-===================================================================
---- timestamp_tools.orig/include/timestamp_tools/trigger_matcher.h
-+++ timestamp_tools/include/timestamp_tools/trigger_matcher.h
-@@ -266,7 +266,7 @@ public:
- if (stamp != RetryLater)
- return stamp;
-
-- got_trigger_condition_.timed_wait(lock, boost::posix_time::microseconds(timeout * 1e6));
-+ got_trigger_condition_.timed_wait(lock, boost::posix_time::microseconds(static_cast<int>(timeout * 1e6)));
-
- return getTimestampNoblockPrelocked(t);
- }
diff --git a/dev-ros/timestamp_tools/files/tests.patch b/dev-ros/timestamp_tools/files/tests.patch
deleted file mode 100644
index d66118537ed3..000000000000
--- a/dev-ros/timestamp_tools/files/tests.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Index: driver_common-1.6.8/timestamp_tools/CMakeLists.txt
-===================================================================
---- driver_common-1.6.8.orig/CMakeLists.txt
-+++ driver_common-1.6.8/CMakeLists.txt
-@@ -17,5 +17,7 @@ install(DIRECTORY include/${PROJECT_NAME
- DESTINATION ${CATKIN_PACKAGE_INCLUDE_DESTINATION}
- FILES_MATCHING PATTERN "*.h")
-
-+if(CATKIN_ENABLE_TESTING)
- catkin_add_gtest(test_trigger_matcher test/test_trigger_matcher.cpp)
--target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
-\ No newline at end of file
-+target_link_libraries(test_trigger_matcher ${catkin_LIBRARIES})
-+endif()
diff --git a/dev-ros/timestamp_tools/timestamp_tools-1.6.8-r1.ebuild b/dev-ros/timestamp_tools/timestamp_tools-1.6.8-r1.ebuild
deleted file mode 100644
index 52ab3c68a490..000000000000
--- a/dev-ros/timestamp_tools/timestamp_tools-1.6.8-r1.ebuild
+++ /dev/null
@@ -1,22 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
-KEYWORDS="~amd64 ~arm"
-ROS_SUBDIR=${PN}
-
-inherit ros-catkin
-
-DESCRIPTION="Classes to help timestamp hardware events"
-LICENSE="BSD"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- dev-ros/roslib
- dev-ros/roscpp
-"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )"
-PATCHES=( "${FILESDIR}/tests.patch" "${FILESDIR}/boost.patch" )