summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-24 12:11:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-24 13:29:43 +0300
commit2509b046d527274b476580b7067e3f9c4d681a46 (patch)
tree71fc65c52865e2b6d52d49d584ca40d81a0065ee /dev-ros
parentdev-ros/ament_cmake_copyright: enable py3.9, enable py3.10 (diff)
downloadgentoo-2509b046d527274b476580b7067e3f9c4d681a46.tar.gz
gentoo-2509b046d527274b476580b7067e3f9c4d681a46.tar.bz2
gentoo-2509b046d527274b476580b7067e3f9c4d681a46.zip
dev-ros/ament_xmllint: enable py3.9
passes tests Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/ament_xmllint/ament_xmllint-0.11.2.ebuild17
-rw-r--r--dev-ros/ament_xmllint/ament_xmllint-9999.ebuild17
2 files changed, 10 insertions, 24 deletions
diff --git a/dev-ros/ament_xmllint/ament_xmllint-0.11.2.ebuild b/dev-ros/ament_xmllint/ament_xmllint-0.11.2.ebuild
index dc712bff4c31..1cd644ad005b 100644
--- a/dev-ros/ament_xmllint/ament_xmllint-0.11.2.ebuild
+++ b/dev-ros/ament_xmllint/ament_xmllint-0.11.2.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,11 +12,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Checks XML files like the package manifest using xmllint"
@@ -24,25 +24,18 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
RDEPEND="
dev-ros/ament_lint[${PYTHON_USEDEP}]
dev-libs/libxml2[python,${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
dev-ros/ament_copyright[${PYTHON_USEDEP}]
dev-ros/ament_flake8[${PYTHON_USEDEP}]
dev-ros/ament_pep257[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-BDEPEND=""
distutils_enable_tests pytest
diff --git a/dev-ros/ament_xmllint/ament_xmllint-9999.ebuild b/dev-ros/ament_xmllint/ament_xmllint-9999.ebuild
index dc712bff4c31..1cd644ad005b 100644
--- a/dev-ros/ament_xmllint/ament_xmllint-9999.ebuild
+++ b/dev-ros/ament_xmllint/ament_xmllint-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python{3_7,3_8} )
+PYTHON_COMPAT=( python3_{8..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -12,11 +12,11 @@ ROS_PN="ament_lint"
if [ "${PV#9999}" != "${PV}" ] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/ament/ament_lint"
- SRC_URI=""
- S=${WORKDIR}/${P}/${PN}
+ S="${WORKDIR}/${P}/${PN}"
else
SRC_URI="https://github.com/ament/ament_lint/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+ KEYWORDS="~amd64"
fi
DESCRIPTION="Checks XML files like the package manifest using xmllint"
@@ -24,25 +24,18 @@ HOMEPAGE="https://github.com/ament/ament_lint"
LICENSE="Apache-2.0"
SLOT="0"
-if [ "${PV#9999}" != "${PV}" ] ; then
- PROPERTIES="live"
-else
- KEYWORDS="~amd64"
-fi
-IUSE="test"
RDEPEND="
dev-ros/ament_lint[${PYTHON_USEDEP}]
dev-libs/libxml2[python,${PYTHON_USEDEP}]
"
-DEPEND="${RDEPEND}
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
dev-ros/ament_copyright[${PYTHON_USEDEP}]
dev-ros/ament_flake8[${PYTHON_USEDEP}]
dev-ros/ament_pep257[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
)
"
-BDEPEND=""
distutils_enable_tests pytest