summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-10-06 09:21:21 +0200
committerHans de Graaff <graaff@gentoo.org>2024-10-06 09:40:11 +0200
commitdd9399c13e7ea8b921590fb49bf8c8585d2fd4da (patch)
tree380c465806eece9f4d2f247216f44b07f1bd6609 /dev-ruby/acts_as_list
parentapp-text/webgen: enable ruby33 (diff)
downloadgentoo-dd9399c13e7ea8b921590fb49bf8c8585d2fd4da.tar.gz
gentoo-dd9399c13e7ea8b921590fb49bf8c8585d2fd4da.tar.bz2
gentoo-dd9399c13e7ea8b921590fb49bf8c8585d2fd4da.zip
dev-ruby/acts_as_list: drop 1.1.0, 1.2.0, 1.2.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/acts_as_list')
-rw-r--r--dev-ruby/acts_as_list/Manifest3
-rw-r--r--dev-ruby/acts_as_list/acts_as_list-1.1.0.ebuild38
-rw-r--r--dev-ruby/acts_as_list/acts_as_list-1.2.0.ebuild42
-rw-r--r--dev-ruby/acts_as_list/acts_as_list-1.2.1.ebuild42
4 files changed, 0 insertions, 125 deletions
diff --git a/dev-ruby/acts_as_list/Manifest b/dev-ruby/acts_as_list/Manifest
index a75723d690c9..2e053b8a4265 100644
--- a/dev-ruby/acts_as_list/Manifest
+++ b/dev-ruby/acts_as_list/Manifest
@@ -1,4 +1 @@
-DIST acts_as_list-1.1.0.gem 41984 BLAKE2B abeb0325795276294451b4cb86e20dab6871003c72679ce28f9326cd844234ad56457a03d9b9ecd81b8c143deeefc25dd15df88a38ebdd1324a953b2399465e7 SHA512 bdcaf07bc4ad3854d68c8d95e666e86c2500474ffa212c315b6b4abd321341ac782c0e301f2c859c12b80ecfdd1cc743ccf8a7bdbdb36e30fafcd98d4928a00a
-DIST acts_as_list-1.2.0.gem 41984 BLAKE2B 98652e8b974501a499fb06f73807adfca411912f7b6e705ca91f654b814c61d419018af068ea4977abae55b6ebcea7d2dd7c48a2b107f0d31f1027799875978a SHA512 16e5b5549db7884077b3fe3131b1f91f3b857a083ab80b9b1c19a59b25740b53b032081743f222850fd06cc5892164e0c06cc0c63ae35cf646920f5e7d87292d
-DIST acts_as_list-1.2.1.gem 42496 BLAKE2B ba7d009db1a0cabaea360401df3dbaddbae4d94cf4f9be2d6f9001c1be720d17a5ec7556723878923e85ad9acd231af8c5014f393aff0744bae0c110b01101a6 SHA512 095d402c49f855cd1274e3ca3afdcbdd4e4d747c7bf2d0a010257c14de8751a13da889273acf9fa134c7da12d7bb92474377c8f6082bc7b9fa919c67d992bebc
DIST acts_as_list-1.2.2.tar.gz 38316 BLAKE2B 8fca217bab42ec45f8860323347e0d5282c99b494588f84f623cbb395bbf1cbeaa8cd8c7fd5344a7c1900a65a3a5f263ffd11fc340e2a0533dc8cbddc297d2a8 SHA512 1e985593b849cb4da5749bce72d09354454b06e40eeefbba161b0e8ceeccf08702761793692213bce013848151de373f0407d7794e7d1745e60646070e4946d7
diff --git a/dev-ruby/acts_as_list/acts_as_list-1.1.0.ebuild b/dev-ruby/acts_as_list/acts_as_list-1.1.0.ebuild
deleted file mode 100644
index 1ea325ddf3e6..000000000000
--- a/dev-ruby/acts_as_list/acts_as_list-1.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby30 ruby31 ruby32"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-DESCRIPTION="Capabilities for sorting and reordering a number of objects in a list"
-HOMEPAGE="https://github.com/brendon/acts_as_list"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/activerecord-4.2:*"
-
-ruby_add_bdepend "
- test? (
- dev-ruby/mocha
- dev-ruby/test-unit:2
- dev-ruby/timecop
- dev-ruby/activerecord[sqlite]
- )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/bundler/,/^end/ s:^:#:' test/helper.rb || die
- sed -i -e '/git ls/d' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/github_changelog/,$ s:^:#:' Rakefile || die
-}
diff --git a/dev-ruby/acts_as_list/acts_as_list-1.2.0.ebuild b/dev-ruby/acts_as_list/acts_as_list-1.2.0.ebuild
deleted file mode 100644
index c33afe589595..000000000000
--- a/dev-ruby/acts_as_list/acts_as_list-1.2.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32 ruby33"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-DESCRIPTION="Capabilities for sorting and reordering a number of objects in a list"
-HOMEPAGE="https://github.com/brendon/acts_as_list"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend ">=dev-ruby/activerecord-6.1:* >=dev-ruby/activesupport-6.1:*"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/mocha-2.1.0:2
- dev-ruby/test-unit:2
- dev-ruby/timecop
- dev-ruby/activerecord[sqlite]
- )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/bundler/,/^end/ s:^:#:' test/helper.rb || die
- sed -i -e '/git ls/d' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/github_changelog/,$ s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- DB=sqlite each_fakegem_test
-}
diff --git a/dev-ruby/acts_as_list/acts_as_list-1.2.1.ebuild b/dev-ruby/acts_as_list/acts_as_list-1.2.1.ebuild
deleted file mode 100644
index c33afe589595..000000000000
--- a/dev-ruby/acts_as_list/acts_as_list-1.2.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby31 ruby32 ruby33"
-
-inherit ruby-fakegem
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-RUBY_FAKEGEM_EXTRAINSTALL="init.rb"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-DESCRIPTION="Capabilities for sorting and reordering a number of objects in a list"
-HOMEPAGE="https://github.com/brendon/acts_as_list"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~amd64"
-IUSE="test"
-
-ruby_add_rdepend ">=dev-ruby/activerecord-6.1:* >=dev-ruby/activesupport-6.1:*"
-
-ruby_add_bdepend "
- test? (
- >=dev-ruby/mocha-2.1.0:2
- dev-ruby/test-unit:2
- dev-ruby/timecop
- dev-ruby/activerecord[sqlite]
- )"
-
-all_ruby_prepare() {
- rm Gemfile || die
- sed -i -e '/[Bb]undler/d' Rakefile || die
- sed -i -e '/bundler/,/^end/ s:^:#:' test/helper.rb || die
- sed -i -e '/git ls/d' ${RUBY_FAKEGEM_GEMSPEC} || die
- sed -i -e '/github_changelog/,$ s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- DB=sqlite each_fakegem_test
-}