summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-09-15 08:59:06 +0200
committerHans de Graaff <graaff@gentoo.org>2020-09-15 09:33:51 +0200
commitfd94ea67ea3ecca57b73b22e1c49865803fd0151 (patch)
treee657f6ad1bf5a87ddc9a159e90eb67f29baffaff /dev-ruby/bunny/bunny-2.17.0.ebuild
parentsys-process/evisum: remove old 0.5.4 (diff)
downloadgentoo-fd94ea67ea3ecca57b73b22e1c49865803fd0151.tar.gz
gentoo-fd94ea67ea3ecca57b73b22e1c49865803fd0151.tar.bz2
gentoo-fd94ea67ea3ecca57b73b22e1c49865803fd0151.zip
dev-ruby/bunny: add 2.17.0
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/bunny/bunny-2.17.0.ebuild')
-rw-r--r--dev-ruby/bunny/bunny-2.17.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/bunny/bunny-2.17.0.ebuild b/dev-ruby/bunny/bunny-2.17.0.ebuild
new file mode 100644
index 000000000000..7bc6776b0c7e
--- /dev/null
+++ b/dev-ruby/bunny/bunny-2.17.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+# Tests require a live AMQP server.
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Another synchronous Ruby AMQP client"
+HOMEPAGE="https://github.com/celldee/bunny"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/amq-protocol-2.3.1:2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ dodoc -r examples
+}