summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/factory_girl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/factory_girl')
-rw-r--r--dev-ruby/factory_girl/Manifest1
-rw-r--r--dev-ruby/factory_girl/factory_girl-4.5.0.ebuild47
-rw-r--r--dev-ruby/factory_girl/metadata.xml13
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/factory_girl/Manifest b/dev-ruby/factory_girl/Manifest
new file mode 100644
index 000000000000..565ed2c5bd5f
--- /dev/null
+++ b/dev-ruby/factory_girl/Manifest
@@ -0,0 +1 @@
+DIST factory_girl-4.5.0.gem 64000 SHA256 4078a55b2ca6f56c8cde9af1d4d6f14f9bf040ff9e141474fdb6c51ad422c362 SHA512 0d202ffddbf3d7479446e3deb951f3266d67063242ee1b930034b277f3b228326dc99feab0f5b61db64ef973bdd1e77d3d3fc57f6d84f9026c04c2f480423da7 WHIRLPOOL 5bca2ca7b4e812ef8f157cc59f9c673989dbff0c6a8518734b2e2e3877aff8c0637ec5f184fddaea563c55505f2c2e0f69f70e899a9fb92db92db590dab91f20
diff --git a/dev-ruby/factory_girl/factory_girl-4.5.0.ebuild b/dev-ruby/factory_girl/factory_girl-4.5.0.ebuild
new file mode 100644
index 000000000000..a5d758206b6f
--- /dev/null
+++ b/dev-ruby/factory_girl/factory_girl-4.5.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_DOC="yard"
+
+# Tests depend on unpackaged appraisal, for now we just run the specs
+# with the version of Rails that is installed.
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="GETTING_STARTED.md NEWS README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="features"
+
+inherit ruby-fakegem
+
+DESCRIPTION="factory_girl provides a framework and DSL for defining and using factories"
+HOMEPAGE="https://github.com/thoughtbot/factory_girl"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/activesupport-3.0.0:*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/activerecord-3.1[sqlite]
+ dev-ruby/bourne
+ >=dev-ruby/mocha-0.12.8
+ dev-ruby/timecop
+ )
+"
+
+all_ruby_prepare() {
+ # Avoid unneeded test dependencies
+ sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs that may fail due to more strict rspec 2.99
+ # interpretation.
+ sed -i -e '/callbacks using syntax methods without referencing FactoryGirl explicitly/,/^end/ s:^:#:' spec/acceptance/callbacks_spec.rb || die
+}
diff --git a/dev-ruby/factory_girl/metadata.xml b/dev-ruby/factory_girl/metadata.xml
new file mode 100644
index 000000000000..2367cab540d1
--- /dev/null
+++ b/dev-ruby/factory_girl/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>zerochaos@gentoo.org</email>
+ <name>Rick Farina</name>
+ </maintainer>
+ <longdescription lang="en">
+</longdescription>
+ <upstream>
+ <remote-id type="github">thoughtbot/factory_girl</remote-id>
+ </upstream>
+</pkgmetadata>