summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2022-03-18 07:55:26 +0100
committerHans de Graaff <graaff@gentoo.org>2022-03-18 07:55:26 +0100
commitb2ffd2092c0ab2003e0b19a4a6f4ae92462b0db0 (patch)
tree05f91b674a27b92eb27dfca0d54c16bb009ec4e6 /dev-ruby/rack-protection
parentdev-ruby/minitest-global_expectations: add ruby31 (diff)
downloadgentoo-b2ffd2092c0ab2003e0b19a4a6f4ae92462b0db0.tar.gz
gentoo-b2ffd2092c0ab2003e0b19a4a6f4ae92462b0db0.tar.bz2
gentoo-b2ffd2092c0ab2003e0b19a4a6f4ae92462b0db0.zip
dev-ruby/rack-protection: add 2.2.0
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rack-protection')
-rw-r--r--dev-ruby/rack-protection/Manifest1
-rw-r--r--dev-ruby/rack-protection/rack-protection-2.2.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-ruby/rack-protection/Manifest b/dev-ruby/rack-protection/Manifest
index ba7ffb86acc9..df6fa09ab02a 100644
--- a/dev-ruby/rack-protection/Manifest
+++ b/dev-ruby/rack-protection/Manifest
@@ -1 +1,2 @@
DIST rack-protection-2.1.0.gem 17408 BLAKE2B e4804273d346c76e9e7348bfa9575f16c9d415da9db4e8677782aed70fa613b6f322c82808707734276b8db60fce9d87fbbaac807c1b8df7f6bf1960c76ae244 SHA512 965388584a2cae9065ccc0d041bbd40951f22420f05e657586d710f87ae8f854a0be32c3274b9373f96b5f8eb19354d371e3bce9b2df83c013abfea99f16bded
+DIST rack-protection-2.2.0.gem 17408 BLAKE2B d9d5d8e2473b6354dd61cfc338a05932a2c60aa12544399cb0b9b74c717d6fa48bdec638381582be0a13f845f0c69583275f412458a20198894b5eddc7b53358 SHA512 06d6c2026e3e93131a2405bbaa8a514ddde48607979828b9fc41309dbdfff2b7c8cac48a6981e76b5dda554f0cbdc7c6ff5f44b8925fce1cb9b7de0a16380ca4
diff --git a/dev-ruby/rack-protection/rack-protection-2.2.0.ebuild b/dev-ruby/rack-protection/rack-protection-2.2.0.ebuild
new file mode 100644
index 000000000000..d4ddbd88b292
--- /dev/null
+++ b/dev-ruby/rack-protection/rack-protection-2.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# There are no specs in the gem and the source cannot be downloaded separately.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem protects against typical web attacks"
+HOMEPAGE="https://github.com/rkh/rack-protection"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/rack:*"
+
+# ruby_add_bdepend "test? ( dev-ruby/rack-test )"