summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-ruby/rack-test
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-ruby/rack-test')
-rw-r--r--dev-ruby/rack-test/Manifest2
-rw-r--r--dev-ruby/rack-test/metadata.xml8
-rw-r--r--dev-ruby/rack-test/rack-test-0.6.2-r1.ebuild32
-rw-r--r--dev-ruby/rack-test/rack-test-0.6.3.ebuild32
4 files changed, 74 insertions, 0 deletions
diff --git a/dev-ruby/rack-test/Manifest b/dev-ruby/rack-test/Manifest
new file mode 100644
index 000000000000..ca15e830b0ec
--- /dev/null
+++ b/dev-ruby/rack-test/Manifest
@@ -0,0 +1,2 @@
+DIST rack-test-0.6.2.gem 22528 SHA256 7e920b6aac888e4a3846e5997fb1cbf456bdb5846322b58dc31697a54a38b306 SHA512 9c14d75eafea93afb02c4e8fc438f7c653cfe816058560a458a092591214a7fd185b2d76eed7b398e16d72f763e8c7ae0a869c3a29df075102845074568d8ef0 WHIRLPOOL b29abfc46a091aa4ded7bcdc2c68c79720aa42889246bb4df0b52bedf5415ee72f09592bf9af41477544ce34d452e4a7b3c56d9431879a99b58cda7729622865
+DIST rack-test-0.6.3.gem 23552 SHA256 ff60b122e2940e32e94a2e4a61bceb8d9c99a97c1817ecc47e535522b02cdd40 SHA512 a5ad0f20130eedc153515127d2483cb1322c230ab772307943ec6eb295706f3aab26c8599cba69323b3cdc5692b284ba0609d8db957ade7085a95d94ccdf8b41 WHIRLPOOL 033543478a05cd4703a1600f84e7ca74bb7813f3a3bf38afd29784285130b18c5bb0d2fb1fea9aff57bc7f458856969ffc27f8b72dddea20fa79fef9d8ef6189
diff --git a/dev-ruby/rack-test/metadata.xml b/dev-ruby/rack-test/metadata.xml
new file mode 100644
index 000000000000..b79f1cb19cc7
--- /dev/null
+++ b/dev-ruby/rack-test/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">brynary/rack-test</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rack-test/rack-test-0.6.2-r1.ebuild b/dev-ruby/rack-test/rack-test-0.6.2-r1.ebuild
new file mode 100644
index 000000000000..d328b92aa0d8
--- /dev/null
+++ b/dev-ruby/rack-test/rack-test-0.6.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20"
+
+# no documentation is generable, it needs hanna, which is broken
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="Rack::Test is a small, simple testing API for Rack apps"
+HOMEPAGE="http://github.com/brynary/rack-test"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend '>=dev-ruby/rack-1.0'
+ruby_add_bdepend "
+ test? ( >=dev-ruby/sinatra-1.2.6 )"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e '/bundler/d' spec/spec_helper.rb || die
+}
diff --git a/dev-ruby/rack-test/rack-test-0.6.3.ebuild b/dev-ruby/rack-test/rack-test-0.6.3.ebuild
new file mode 100644
index 000000000000..0acaf5d9bdcd
--- /dev/null
+++ b/dev-ruby/rack-test/rack-test-0.6.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+# no documentation is generable, it needs hanna, which is broken
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_EXTRADOC="History.txt README.rdoc"
+
+inherit versionator ruby-fakegem
+
+DESCRIPTION="Rack::Test is a small, simple testing API for Rack apps"
+HOMEPAGE="http://github.com/brynary/rack-test"
+
+LICENSE="MIT"
+SLOT="$(get_version_component_range 1-2)"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rack-1.0:*"
+ruby_add_bdepend "
+ test? ( >=dev-ruby/sinatra-1.2.6 )"
+
+all_ruby_prepare() {
+ rm Gemfile* || die
+ sed -i -e '/bundler/d' -e '/[Cc]ode[Cc]limate/d' spec/spec_helper.rb || die
+}