summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-03-28 08:05:09 +0100
committerHans de Graaff <graaff@gentoo.org>2020-03-28 08:05:35 +0100
commita5bc0c40e167e5a47b9291cb72045699e1e00330 (patch)
treef23566895a9d7a3c00d2feca6749b6fed1fc8eef /dev-ruby/rmagick/rmagick-4.1.0.ebuild
parentdev-util/jenkins-bin: add 2.222.1 (diff)
downloadgentoo-a5bc0c40e167e5a47b9291cb72045699e1e00330.tar.gz
gentoo-a5bc0c40e167e5a47b9291cb72045699e1e00330.tar.bz2
gentoo-a5bc0c40e167e5a47b9291cb72045699e1e00330.zip
dev-ruby/rmagick: add 4.1.0
Closes: https://bugs.gentoo.org/619684 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby/rmagick/rmagick-4.1.0.ebuild')
-rw-r--r--dev-ruby/rmagick/rmagick-4.1.0.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/dev-ruby/rmagick/rmagick-4.1.0.ebuild b/dev-ruby/rmagick/rmagick-4.1.0.ebuild
new file mode 100644
index 000000000000..e4794f1cff3f
--- /dev/null
+++ b/dev-ruby/rmagick/rmagick-4.1.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+MY_PV=RMagick_${PV//\./-}
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="An interface between Ruby and the ImageMagick(TM) image processing library"
+HOMEPAGE="https://github.com/rmagick/rmagick"
+SRC_URI="https://github.com/rmagick/rmagick/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="rmagick-${MY_PV}"
+
+LICENSE="Artistic"
+SLOT="4"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-macos"
+IUSE="doc"
+
+RDEPEND+=" >=media-gfx/imagemagick-6.9.0:="
+DEPEND+=" >=media-gfx/imagemagick-6.9.0:=[jpeg]"
+
+all_ruby_prepare() {
+ # Avoid unused dependency on rake-compiler. This also avoids an
+ # extra compile during tests.
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' \
+ -e '/compile/ s:^:#:' Rakefile || die
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
+
+ # Squelch harmless warning about imagemagick installation.
+ sed -i -e '/prefix/ s:ImageMagick:ImageMagick-6:' ext/RMagick/extconf.rb || die
+
+ # Reading PDFs is not allowed by the default Gentoo security policy for imagemagick
+ sed -i -e '/can read PDF file/askip "Not allowed by Gentoo security policy"' spec/rmagick/image/read_spec.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/RMagick extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake -Cext/RMagick V=1
+ cp ext/RMagick/RMagick2$(get_modname) lib/ || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc examples/*
+
+ if use doc ; then
+ docinto .
+ dodoc -r doc
+ fi
+}