summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2018-08-05 08:40:10 +0200
committerHans de Graaff <graaff@gentoo.org>2018-08-05 08:41:05 +0200
commit2a492853eb61cf2c348ae148d2dcd4e7c2794806 (patch)
tree62c1af618d5cefa56d0300becac01f8e10913f1d /dev-ruby/rspec/rspec-3.8.0.ebuild
parentdev-ruby/rspec-core: add 3.8.0 (diff)
downloadgentoo-2a492853eb61cf2c348ae148d2dcd4e7c2794806.tar.gz
gentoo-2a492853eb61cf2c348ae148d2dcd4e7c2794806.tar.bz2
gentoo-2a492853eb61cf2c348ae148d2dcd4e7c2794806.zip
dev-ruby/rspec: add 3.8.0
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-ruby/rspec/rspec-3.8.0.ebuild')
-rw-r--r--dev-ruby/rspec/rspec-3.8.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/rspec/rspec-3.8.0.ebuild b/dev-ruby/rspec/rspec-3.8.0.ebuild
new file mode 100644
index 000000000000..17f8f7cf8ca8
--- /dev/null
+++ b/dev-ruby/rspec/rspec-3.8.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem eapi7-ver
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec"
+
+LICENSE="MIT"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "
+ =dev-ruby/rspec-core-${SUBVERSION}*
+ =dev-ruby/rspec-expectations-${SUBVERSION}*
+ =dev-ruby/rspec-mocks-${SUBVERSION}*"