summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-08-13 09:29:43 +0200
committerHans de Graaff <graaff@gentoo.org>2024-08-13 09:29:43 +0200
commit00b2f6200542ab6f47ee461d15691d55fab5c339 (patch)
treedaace5e5014cdadfbb9a6c8845b14ccff827cbfd /dev-ruby
parentdev-ruby/faraday-rack: fix tests, add missing test dependency (diff)
downloadgentoo-00b2f6200542ab6f47ee461d15691d55fab5c339.tar.gz
gentoo-00b2f6200542ab6f47ee461d15691d55fab5c339.tar.bz2
gentoo-00b2f6200542ab6f47ee461d15691d55fab5c339.zip
dev-ruby/date_validator: fix tests
Ensure a valid activemodel version is used. Closes: https://bugs.gentoo.org/937847 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/date_validator/date_validator-0.12.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-ruby/date_validator/date_validator-0.12.0.ebuild b/dev-ruby/date_validator/date_validator-0.12.0.ebuild
index 8b174b7e9552..d00447da313f 100644
--- a/dev-ruby/date_validator/date_validator-0.12.0.ebuild
+++ b/dev-ruby/date_validator/date_validator-0.12.0.ebuild
@@ -24,7 +24,7 @@ HOMEPAGE="https://github.com/codegram/date_validator"
LICENSE="MIT"
SLOT="3"
KEYWORDS="~amd64"
-IUSE=""
+IUSE="doc test"
ruby_add_rdepend "
>=dev-ruby/activemodel-3.0:*
@@ -46,5 +46,6 @@ all_ruby_prepare() {
sed -i \
-e '/[Bb]undler/s/^/#/' Rakefile || die
# Fix tests
- sed -i -e "1irequire 'active_support'; require 'active_support/core_ext/time/zones'" test/test_helper.rb || die
+ sed -e "1igem 'activemodel'; require 'active_support'; require 'active_support/core_ext/time/zones'" \
+ -i test/test_helper.rb || die
}