summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-04-14 07:51:08 +0200
committerHans de Graaff <graaff@gentoo.org>2023-04-14 07:51:08 +0200
commit5596ae30830de4dc88d4aa54c0bafd40a8070476 (patch)
treeaec1b40de289a6dbc14bdbe791bec5635de7c332 /dev-ruby
parentdev-ruby/rspec-rails: enable ruby31 (diff)
downloadgentoo-5596ae30830de4dc88d4aa54c0bafd40a8070476.tar.gz
gentoo-5596ae30830de4dc88d4aa54c0bafd40a8070476.tar.bz2
gentoo-5596ae30830de4dc88d4aa54c0bafd40a8070476.zip
dev-ruby/ox: add 2.14.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/ox/Manifest1
-rw-r--r--dev-ruby/ox/ox-2.14.16.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/ox/Manifest b/dev-ruby/ox/Manifest
index 242ab852ac59..ef84bca3b9d7 100644
--- a/dev-ruby/ox/Manifest
+++ b/dev-ruby/ox/Manifest
@@ -1,2 +1,3 @@
DIST ox-2.14.13.tar.gz 219129 BLAKE2B a80e2edd9b987f49444a05005b472695d56f7c88a90e42b6b2a2a0d9fea593651ac544731c796bc273ac78dee61294d883476bcd43b5101ada08c9f60f0b2702 SHA512 a909a8f65c79b7d1c4e131e122d0c98c0f7ce3ff46837343ea068ee5a0055904eb0f992b553b3634edf577fca3c6c365243a64bc3719fca5e9e14fe16ed7f192
DIST ox-2.14.14.tar.gz 219172 BLAKE2B 83fb938662ca7426289a96597a7a2bd74a47a0bbaa67316e3320a1e6090d15d371867ecb1b034e6dfdf2a6a8f288ea2fdfa4fddf138b492fca7b1d5faba476e1 SHA512 f4b3ed29c50bd39b22cae91d82ec8780f779f8a39a83402b9f692407c4742b87df23a5912978753e45c4a062967018fdfa3a65234e983fa0494528523a322f1c
+DIST ox-2.14.16.tar.gz 224723 BLAKE2B 51c8e6d817f6e6fc302ddd6b7cb3a9899a6c7898ef6f602b20accb88b9126e6490a33bb7bb1382a087e05bbe287d5838b5d8652f4f6a96013f5fd4ba619e6075 SHA512 211cbf48fb580c339e57e352991b7be98efc8490ba97b559c61fd573853e26fcba87b7e0e05c720ecab9ef188b9d0d2cbd511620b197c5341c6bdb02370ffcb3
diff --git a/dev-ruby/ox/ox-2.14.16.ebuild b/dev-ruby/ox/ox-2.14.16.ebuild
new file mode 100644
index 000000000000..8fb552f6375f
--- /dev/null
+++ b/dev-ruby/ox/ox-2.14.16.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_GEMSPEC="ox.gemspec"
+
+RUBY_FAKEGEM_EXTENSIONS=(ext/ox/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR=lib/ox
+
+inherit ruby-fakegem
+
+DESCRIPTION="A fast XML parser and Object marshaller"
+HOMEPAGE="https://www.ohler.com/ox/ https://github.com/ohler55/ox"
+SRC_URI="https://github.com/ohler55/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+SLOT="0"
+IUSE=""
+
+each_ruby_test() {
+ ${RUBY} test/tests.rb || die
+}