summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-13 07:24:12 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-14 06:48:37 +0100
commit63ca8781618a413b992d41ae6aa3dabd0e7083a7 (patch)
tree28ebe23e2f0a4bad629fe0fea4dd1ac6cf60bc92 /dev-ruby
parentdev-ruby/rbs: add 3.4.4 (diff)
downloadgentoo-63ca8781618a413b992d41ae6aa3dabd0e7083a7.tar.gz
gentoo-63ca8781618a413b992d41ae6aa3dabd0e7083a7.tar.bz2
gentoo-63ca8781618a413b992d41ae6aa3dabd0e7083a7.zip
dev-ruby/http: add 5.2.0
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/http/Manifest1
-rw-r--r--dev-ruby/http/http-5.2.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/http/Manifest b/dev-ruby/http/Manifest
index 3b126b27c40d..e231bb5237ff 100644
--- a/dev-ruby/http/Manifest
+++ b/dev-ruby/http/Manifest
@@ -1 +1,2 @@
DIST http-5.1.1.gem 82944 BLAKE2B bd44ede401712ddd13b76f9e3266622aefd78f37a89c84217c7f8206214e9e2ee994fe375a6e7897315dd83853d4e8ab2c0c9c34a59fe47c1a0617f3c126fdab SHA512 a39d88297b6f2f0a51a22fe502d1f7883d44a3fa0af250e1a8142f093fb3865b02b797bc46780d9129f0c67e18f97cc551aa1dbd794b3b4cda6bdb5495fe95e3
+DIST http-5.2.0.gem 85504 BLAKE2B 60391b959752c63e2f8cffcb86d6aad47fd30817f348ac6fc28ebce4fa5186f482c08db5e4413fc84eb54a9beb2682260c0c7241a76b40c3489fe7f2abcfb154 SHA512 88a813498db68827ea665c3a568ce45b0096203484564f3de18d46abdd87d2ecd756745f9f530965db306f8e37185d3d0b31959082bbe01fee5545b36b0716bd
diff --git a/dev-ruby/http/http-5.2.0.ebuild b/dev-ruby/http/http-5.2.0.ebuild
new file mode 100644
index 000000000000..ed0481107d6c
--- /dev/null
+++ b/dev-ruby/http/http-5.2.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md CHANGES_OLD.md README.md"
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+inherit ruby-fakegem
+
+DESCRIPTION="An easy-to-use client library for making requests from Ruby"
+HOMEPAGE="https://github.com/httprb/http"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="test"
+
+ruby_add_rdepend "=dev-ruby/addressable-2*
+ >=dev-ruby/addressable-2.8
+ =dev-ruby/base64-0*:*
+ =dev-ruby/http-cookie-1*
+ >=dev-ruby/http-form_data-2.2:2
+ >=dev-ruby/llhttp-ffi-0.5.0:0/0.5"
+
+ruby_add_bdepend "
+ test? (
+ =dev-ruby/certificate_authority-1*
+ dev-ruby/rspec-its
+ dev-ruby/webrick
+ )"
+
+all_ruby_prepare() {
+ # Avoid specs that require network access
+ sed -i -e '/.persistent/,/^ end/ s:^:#:' \
+ spec/lib/http_spec.rb || die
+ sed -i -e '/with non-ASCII URLs/,/^ end/ s:^:#:' \
+ spec/lib/http/client_spec.rb || die
+
+ # Avoid spec that may fail with a running web server
+ sed -i -e '/unifies socket errors into HTTP::ConnectionError/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
+
+ # Fix spec for production release
+ sed -i -e '/User-Agent:/ s/.dev//' spec/lib/http/features/logging_spec.rb || die
+
+ # Avoid specs also failing upstream due to some certificate issue
+ sed -i -e '/context "ssl"/,/^ end/ s:^:#:' spec/lib/http_spec.rb || die
+ sed -i -e '/describe "working with SSL"/,/^ end/ s:^:#:' spec/lib/http/client_spec.rb || die
+
+ # Disable coverage
+ sed -i -e 's/require_relative ".\/support\/simplecov"//g' "spec/spec_helper.rb" || die
+}
+
+each_ruby_test() {
+ # disables dev-ruby/fuubar dep
+ CI=1 each_fakegem_test
+}