summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-07 09:36:31 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-07 09:37:35 +0200
commit89bcc98ce7ba0cfe3de2910a9aa12c3f0847db94 (patch)
treef36e15486e87e1a1d98cbbfef14e2203734e526b /dev-ruby
parentdev-ruby/omniauth: add ruby27 (diff)
downloadgentoo-89bcc98ce7ba0cfe3de2910a9aa12c3f0847db94.tar.gz
gentoo-89bcc98ce7ba0cfe3de2910a9aa12c3f0847db94.tar.bz2
gentoo-89bcc98ce7ba0cfe3de2910a9aa12c3f0847db94.zip
dev-ruby/omniauth: add 2.0.4
Bug: https://bugs.gentoo.org/761960 Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/omniauth/Manifest1
-rw-r--r--dev-ruby/omniauth/omniauth-2.0.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-ruby/omniauth/Manifest b/dev-ruby/omniauth/Manifest
index ef5990b98239..414327ceb69d 100644
--- a/dev-ruby/omniauth/Manifest
+++ b/dev-ruby/omniauth/Manifest
@@ -1 +1,2 @@
DIST omniauth-1.9.1.tar.gz 26528 BLAKE2B da096ce924972c867ade4cde7e6ec90f5a7de41947f5d04ad092174baf3073ba6b235ff998551d9bbc7f6dfa2a4290eef1e1d962590591cf29f89395a554f3a9 SHA512 687ab9ad47d57d1cbe01fb7ed37754fecb3b75b7e62853070b5880ad6347a2834524a8d4042271ecd7f708ab35b7b5bd3203058ef03c3317f26f88a7639c2672
+DIST omniauth-2.0.4.tar.gz 30951 BLAKE2B 6086a737e043ae37e6c7c4b1e4d597a08e6dc490c5d71f7847e9c5a8880bbbd1117470efbbe12e150bf238bf6e5413493712f1c09ae5e37f5d7b7676b6da023e SHA512 c92ce881388c9793e96354caee764cbabb28c69ca63b32f304693c4859eb8bf994e86b2cc9dbeb57993347e6f2787c43eab967c36730d5c47a3c4767d16847eb
diff --git a/dev-ruby/omniauth/omniauth-2.0.4.ebuild b/dev-ruby/omniauth/omniauth-2.0.4.ebuild
new file mode 100644
index 000000000000..79e5a2b31ca8
--- /dev/null
+++ b/dev-ruby/omniauth/omniauth-2.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A generalized Rack framework for multiple-provider authentication"
+HOMEPAGE="https://github.com/intridea/omniauth"
+SRC_URI="https://github.com/intridea/omniauth/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64"
+SLOT="$(ver_cut 1)"
+IUSE=""
+
+ruby_add_rdepend "
+ =dev-ruby/rack-2*
+ dev-ruby/rack-protection
+ >=dev-ruby/hashie-3.4.6:*"
+ruby_add_bdepend "doc? ( dev-ruby/yard )
+ test? ( dev-ruby/rack-test )"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' \
+ Rakefile ${PN}.gemspec || die "sed failed"
+ sed -i -e '/RUBY_VERSION/,/^end/ s:^:#: ; /freeze/ s:^:#:' spec/helper.rb || die "sed failed"
+ # maruku fails, resorting to default markdown implementation
+ sed -i -e '/maruku/d' .yardopts || die "sed failed"
+
+ sed -i -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+all_ruby_compile() {
+ all_fakegem_compile
+
+ if use doc ; then
+ yard || die "yard failed"
+ fi
+}