summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-11-08 08:12:05 +0100
committerHans de Graaff <graaff@gentoo.org>2024-11-08 08:12:05 +0100
commitb939141b16f34a37185f6a5c467a84e52ac79929 (patch)
tree3d3dcbf246fbf07e31ba8808e22337cef3fac671 /dev-ruby
parentdev-ruby/reline: drop 0.5.8, 0.5.9 (diff)
downloadgentoo-b939141b16f34a37185f6a5c467a84e52ac79929.tar.gz
gentoo-b939141b16f34a37185f6a5c467a84e52ac79929.tar.bz2
gentoo-b939141b16f34a37185f6a5c467a84e52ac79929.zip
dev-ruby/time: add 0.4.1
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/time/Manifest1
-rw-r--r--dev-ruby/time/time-0.4.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/time/Manifest b/dev-ruby/time/Manifest
index aeba0c144fa3..94302f0de0f0 100644
--- a/dev-ruby/time/Manifest
+++ b/dev-ruby/time/Manifest
@@ -1 +1,2 @@
DIST time-0.4.0.tar.gz 16721 BLAKE2B d1f86380c7c79b05f9174bb103c5c69d3abdd9c65b60c65ea4de0d93715a5dc7b2f4cdb8cce9a2d75512c00485b687bbc79bba45389ea12a78ca3776512e45dc SHA512 c95c1167a305fbdf6d138143afc2b822972614b26d87c323d62e663994beb80d12e26e17dc33fe515b65076c50aa05c1d80bc13b6bc83b481d967c796b7c84be
+DIST time-0.4.1.tar.gz 17233 BLAKE2B b6a7fc2c92f879e19a210ef5db7fa680e699b374df7b180602fd7717e7bf287be51f38a2d9a2680c41994c6e1f82602f3d024d4eaa2eaa1515fb0f85a69e05f7 SHA512 daf7bd8fdafb2a04e94f925e4f32c1077ce1c94a17fe4bdc411aaa945d3ec43d575fba6166c18c1ce4ccbd032708974f02a561961b04efd039621749d239bd57
diff --git a/dev-ruby/time/time-0.4.1.ebuild b/dev-ruby/time/time-0.4.1.ebuild
new file mode 100644
index 000000000000..e98b8bb0a911
--- /dev/null
+++ b/dev-ruby/time/time-0.4.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="time.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Extends the Time class with methods for parsing and conversion"
+HOMEPAGE="https://github.com/ruby/time"
+SRC_URI="https://github.com/ruby/time/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_rdepend "dev-ruby/date"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit dev-ruby/test-unit-ruby-core )"
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -rhelper -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}