summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2023-09-28 06:34:31 +0200
committerHans de Graaff <graaff@gentoo.org>2023-09-28 06:38:02 +0200
commitf6931edbe0b17cd93fd974340bc6aad748a5b620 (patch)
treebdee037faf8bd374338c2584ea0c7a18f274dc74 /dev-ruby
parentdev-perl/File-TreeCreate: Stabilize 0.0.1 x86, #914810 (diff)
downloadgentoo-f6931edbe0b17cd93fd974340bc6aad748a5b620.tar.gz
gentoo-f6931edbe0b17cd93fd974340bc6aad748a5b620.tar.bz2
gentoo-f6931edbe0b17cd93fd974340bc6aad748a5b620.zip
dev-ruby/haml: add 6.1.4
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'dev-ruby')
-rw-r--r--dev-ruby/haml/Manifest1
-rw-r--r--dev-ruby/haml/haml-6.1.4.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-ruby/haml/Manifest b/dev-ruby/haml/Manifest
index ebacb93e112a..33dad6c18c21 100644
--- a/dev-ruby/haml/Manifest
+++ b/dev-ruby/haml/Manifest
@@ -1,3 +1,4 @@
DIST haml-5.2.2.tar.gz 129833 BLAKE2B d68c24c7a3c817d6d364b2ec92b84b4f56f4fffa48b99d17b2df27da35f50b1fb1f69b184a7b21d899c476e0d4c8ad2b940a7cb2995ec24ecdafab8ef61fe393 SHA512 1aec59fab20d8139a5dfedde2007fa8137a377a345e4d30229f9d1140d56cdf970c8ae70e2647e6a408d7fa543a16050f66a8a636efa6a6b1f91ee1ffcc136c1
DIST haml-6.1.1.tar.gz 669644 BLAKE2B 239b3a1fe02bcd1e2981198ba7c54c71ca2af0947102fcea6cd600cc6579294856baa290589a7d3a015e54df8bcecf8e50175cf2189e8f4f9c6f9721a558bcc9 SHA512 7d732be085b41b8f0eec418600a82b51c68301081165aa636fa342ae26b74215a202a4b15e592da980d9a7fbe24bad01399f599770420133c4b6ab7523386fa5
DIST haml-6.1.2.tar.gz 669696 BLAKE2B 81398ca33af69a1cf79cbe6d49d82ca27489584dc8c4082c079606f1f029b99e6b4c6fb350a5b50da31349ca3cbd7b7d2913e521b401634f7442e03279753e18 SHA512 c059b96111c6e477874cf37f0463dd9150d00e2e5261e9dab8251e1f66cacfa647009bf4d7ddd60fd11582c3f41ce06515f5aa448358aa58a9df2c8289660151
+DIST haml-6.1.4.tar.gz 669960 BLAKE2B ae4194a7af653e60ec1f5a494a4f8db61a53c99790a9f859cf294961d6cf2d215ad5d2dc78f61355c65935aca0d5534604f0b2fe77dcaf9d3a6cfd775c173701 SHA512 fe866b524fd2f5e85e458897642cb39a97802fdf728182ae3ca2e828931d5526e0568e771a067161610dbb600d962808f417f9dee8b08ffe4baeb71a5566f502
diff --git a/dev-ruby/haml/haml-6.1.4.ebuild b/dev-ruby/haml/haml-6.1.4.ebuild
new file mode 100644
index 000000000000..87b992e5e5ee
--- /dev/null
+++ b/dev-ruby/haml/haml-6.1.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTENSIONS=(ext/haml/extconf.rb)
+RUBY_FAKEGEM_EXTENSION_LIBDIR="lib/haml"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md FAQ.md README.md REFERENCE.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby web page templating engine"
+HOMEPAGE="https://haml.info/"
+SRC_URI="https://github.com/haml/haml/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+IUSE="doc test"
+
+ruby_add_rdepend ">=dev-ruby/temple-0.8.2 dev-ruby/thor dev-ruby/tilt:*"
+
+ruby_add_bdepend "
+ test? (
+ dev-ruby/minitest:5.15
+ dev-ruby/nokogiri
+ >=dev-ruby/railties-6.0
+ >=dev-ruby/activemodel-6.0
+ >=dev-ruby/actionpack-6.0
+ dev-ruby/unindent
+ )
+ doc? (
+ dev-ruby/yard
+ )"
+
+all_ruby_prepare() {
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ sed -i -e '/bundler/ s:^:#: ; /Bundler/,/end/ s:^:#:' Rakefile || die
+ # minitest hack just to match rails/activesupport
+ sed -i \
+ -e "/require 'minitest\/autorun'/igem 'minitest', '< 5.16'" \
+ -e '/bundler/I s:^:#:' \
+ -e '/simplecov/I s:^:#:' \
+ test/test_helper.rb || die
+ # Remove tests that fails when RedCloth is available
+ rm -f test/haml/filters/markdown_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -rtest_helper -e 'Dir["test/haml/**/*_test.rb"].each { require _1 }' || die
+}