summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-05-17 14:53:59 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-05-17 15:18:09 +0200
commit4add1ce6ed03c5de84c75b8823273fc912ba58e8 (patch)
tree46d5be00c86e7c5bbdaa9ef14764e15b90c66262 /dev-scheme/guile-gi/guile-gi-9999.ebuild
parentdev-util/cscope: keyword 15.9 for ~loong (diff)
downloadgentoo-4add1ce6ed03c5de84c75b8823273fc912ba58e8.tar.gz
gentoo-4add1ce6ed03c5de84c75b8823273fc912ba58e8.tar.bz2
gentoo-4add1ce6ed03c5de84c75b8823273fc912ba58e8.zip
dev-scheme/guile-gi: add static-libs USE flag
Closes: https://bugs.gentoo.org/845162 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme/guile-gi/guile-gi-9999.ebuild')
-rw-r--r--dev-scheme/guile-gi/guile-gi-9999.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-scheme/guile-gi/guile-gi-9999.ebuild b/dev-scheme/guile-gi/guile-gi-9999.ebuild
index e1dbe9e8b9ec..b5423a07a2d3 100644
--- a/dev-scheme/guile-gi/guile-gi-9999.ebuild
+++ b/dev-scheme/guile-gi/guile-gi-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,7 +8,7 @@ inherit virtualx autotools
DESCRIPTION="Bindings for GObject Introspection and libgirepository for Guile"
HOMEPAGE="https://spk121.github.io/guile-gi/"
-if [[ "${PV}" == *9999* ]]; then
+if [[ "${PV}" == *9999* ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/spk121/${PN}.git"
else
@@ -16,9 +16,10 @@ else
KEYWORDS="~amd64"
fi
-RESTRICT="strip"
LICENSE="GPL-3"
SLOT="0"
+IUSE="static-libs"
+RESTRICT="strip"
DEPEND="
>=dev-scheme/guile-2.0.9:=
@@ -42,7 +43,7 @@ src_prepare() {
}
src_configure() {
- econf --enable-introspection=yes
+ econf --enable-introspection=yes $(use_enable static-libs static)
}
src_test() {
@@ -53,4 +54,8 @@ src_install() {
default
mv "${D}"/usr/share/doc/${PN} "${D}"/usr/share/doc/${PF} || die
+
+ if ! use static-libs ; then
+ find "${ED}" -type f -name '*.la' -delete || die
+ fi
}