summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2023-08-11 15:36:22 +0200
committerMaciej Barć <xgqt@gentoo.org>2023-08-11 15:53:21 +0200
commita0945dd6b183a559d92dc46fc0b85d949fef59d7 (patch)
tree6577f92729fff2f0c2d61863240702e6099b79ef /dev-scheme
parentdev-scheme/owl-lisp: drop old 0.2 (diff)
downloadgentoo-a0945dd6b183a559d92dc46fc0b85d949fef59d7.tar.gz
gentoo-a0945dd6b183a559d92dc46fc0b85d949fef59d7.tar.bz2
gentoo-a0945dd6b183a559d92dc46fc0b85d949fef59d7.zip
dev-scheme/owl-lisp: skip char-ready, decouple tests
Closes: https://bugs.gentoo.org/912068 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-scheme')
-rw-r--r--dev-scheme/owl-lisp/files/owl-lisp-0.2.1-make-no-test.patch10
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild18
-rw-r--r--dev-scheme/owl-lisp/owl-lisp-9999.ebuild27
3 files changed, 40 insertions, 15 deletions
diff --git a/dev-scheme/owl-lisp/files/owl-lisp-0.2.1-make-no-test.patch b/dev-scheme/owl-lisp/files/owl-lisp-0.2.1-make-no-test.patch
new file mode 100644
index 000000000000..34a4b8ab2288
--- /dev/null
+++ b/dev-scheme/owl-lisp/files/owl-lisp-0.2.1-make-no-test.patch
@@ -0,0 +1,10 @@
+--- a/Makefile
++++ b/Makefile
+@@ -49,7 +49,6 @@ c/ol.c: fasl/ol.fasl
+ bin/ol: c/ol.c
+ # compile the real owl repl binary
+ $(CC) $(CFLAGS) $(LDFLAGS) -o bin/olp $?
+- CC="$(CC)" LDFLAGS="$(LDFLAGS)" CFLAGS="$(CFLAGS)" sh tests/run all bin/olp
+ test '!' -f $@ || mv $@ bin/ol-old
+ mv bin/olp $@
+
diff --git a/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild b/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
index 9a3d4efc4581..569d3b931745 100644
--- a/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
+++ b/dev-scheme/owl-lisp/owl-lisp-0.2.1.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
-
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Purely functional dialect of Scheme"
-HOMEPAGE="https://haltp.org/posts/owl.html"
+HOMEPAGE="https://haltp.org/posts/owl.html
+ https://gitlab.com/owl-lisp/owl/"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
@@ -22,10 +21,15 @@ fi
LICENSE="MIT"
SLOT="0"
+PATCHES=( "${FILESDIR}"/${PN}-0.2.1-make-no-test.patch )
+
src_prepare() {
default
sed -i 's|make bin/vm|$(MAKE) bin/vm|g' "${S}"/Makefile || die
+
+ # Skip "tests/char-ready.sh", "does not work in background subshell".
+ rm tests/char-ready.sh || die
}
src_compile(){
@@ -33,9 +37,11 @@ src_compile(){
}
src_install() {
- einstalldocs
+ exeinto /usr/bin
+ doexe "${S}"/bin/ol
+ newexe "${S}"/bin/vm ovm
- dobin "${S}"/bin/ol
- newbin "${S}"/bin/vm ovm
doman "${S}"/doc/*.1
+
+ einstalldocs
}
diff --git a/dev-scheme/owl-lisp/owl-lisp-9999.ebuild b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
index 551dda855179..b1789ff9873e 100644
--- a/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
+++ b/dev-scheme/owl-lisp/owl-lisp-9999.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# NOTICE: Because it is "purely functional" it is not scheme-compatible ootb
-
EAPI=8
inherit toolchain-funcs
DESCRIPTION="Purely functional dialect of Scheme"
-HOMEPAGE="https://haltp.org/posts/owl.html"
+HOMEPAGE="https://haltp.org/posts/owl.html
+ https://gitlab.com/owl-lisp/owl/"
if [[ "${PV}" == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://gitlab.com/owl-lisp/owl.git"
else
- SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v${PV}/owl-v${PV}.tar.gz"
+ SRC_URI="https://gitlab.com/owl-lisp/owl/-/archive/v${PV}/owl-v${PV}.tar.bz2"
KEYWORDS="~amd64"
S="${WORKDIR}/owl-v${PV}"
fi
@@ -22,15 +21,25 @@ fi
LICENSE="MIT"
SLOT="0"
+PATCHES=( "${FILESDIR}"/${PN}-0.2.1-make-no-test.patch )
+
+src_prepare() {
+ default
+
+ # Skip "tests/char-ready.sh", "does not work in background subshell".
+ rm tests/char-ready.sh || die
+}
+
src_compile(){
emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" owl
}
src_install() {
- einstalldocs
+ exeinto /usr/bin
+ doexe "${S}"/bin/ol
+ newexe "${S}"/bin/vm ovm
- dobin ./bin/ol
- newbin ./bin/vm ovm
+ doman "${S}"/doc/*.1
- doman ./doc/*.1
+ einstalldocs
}