summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-tcltk/tklib
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-tcltk/tklib')
-rw-r--r--dev-tcltk/tklib/Manifest1
-rw-r--r--dev-tcltk/tklib/metadata.xml8
-rw-r--r--dev-tcltk/tklib/tklib-0.6-r1.ebuild37
-rw-r--r--dev-tcltk/tklib/tklib-0.6-r2.ebuild37
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-tcltk/tklib/Manifest b/dev-tcltk/tklib/Manifest
new file mode 100644
index 000000000000..dc6293f778d9
--- /dev/null
+++ b/dev-tcltk/tklib/Manifest
@@ -0,0 +1 @@
+DIST tklib-0.6.tar.bz2 5637725 SHA256 d2e0648bdaf1ab0f874136f1e5645bd68a8fe206f1905d9f08614d90ee2e3025 SHA512 c4dbe6afe9d1d9c97edc154c807d429086e045f8b202870f21cafcd846b7ff759c8260d44d5e1e1322a0e7d3478c1dfb12d7a0c76200f583ac3bb85b21bf04b4 WHIRLPOOL afeb8f62d58f540eb7ecc99c150c719411a41e585ac09a868896484266e69f85ece4c408bc176d4cc87f123280b584b27b29780e8b9d2f58d22a8dae98b8d5d9
diff --git a/dev-tcltk/tklib/metadata.xml b/dev-tcltk/tklib/metadata.xml
new file mode 100644
index 000000000000..e5c951f2dd1c
--- /dev/null
+++ b/dev-tcltk/tklib/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>tcltk</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-tcltk/tklib/tklib-0.6-r1.ebuild b/dev-tcltk/tklib/tklib-0.6-r1.ebuild
new file mode 100644
index 000000000000..26eaef01eb51
--- /dev/null
+++ b/dev-tcltk/tklib/tklib-0.6-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+CODE=6a397dec6188148cf6a6fe290cf2bd92a9190c42
+
+DESCRIPTION="Collection of utility modules for Tk, and a companion to Tcllib"
+HOMEPAGE="http://www.tcl.tk/software/tklib"
+SRC_URI="http://core.tcl.tk/tklib/raw/tklib-0.6.tar.bz2?name=${CODE} -> ${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+IUSE="doc"
+
+RDEPEND="
+ dev-lang/tk:0
+ dev-tcltk/tcllib"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+ if use doc; then
+ emake DESTDIR="${D}" doc
+ dohtml doc/html/*
+ fi
+ dodoc DESCRIPTION.txt README*
+ dosym ${PN}${PV} /usr/$(get_libdir)/${PN}
+
+ mv "${ED}"/usr/share/man/mann/datefield{,-${PN}}.n || die
+ mv "${ED}"/usr/share/man/mann/menubar{,-${PN}}.n || die
+ mv "${ED}"/usr/bin/dia{,-${PN}} || die
+}
diff --git a/dev-tcltk/tklib/tklib-0.6-r2.ebuild b/dev-tcltk/tklib/tklib-0.6-r2.ebuild
new file mode 100644
index 000000000000..26eaef01eb51
--- /dev/null
+++ b/dev-tcltk/tklib/tklib-0.6-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+CODE=6a397dec6188148cf6a6fe290cf2bd92a9190c42
+
+DESCRIPTION="Collection of utility modules for Tk, and a companion to Tcllib"
+HOMEPAGE="http://www.tcl.tk/software/tklib"
+SRC_URI="http://core.tcl.tk/tklib/raw/tklib-0.6.tar.bz2?name=${CODE} -> ${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+LICENSE="BSD"
+IUSE="doc"
+
+RDEPEND="
+ dev-lang/tk:0
+ dev-tcltk/tcllib"
+DEPEND="${RDEPEND}"
+
+src_install() {
+ default
+ if use doc; then
+ emake DESTDIR="${D}" doc
+ dohtml doc/html/*
+ fi
+ dodoc DESCRIPTION.txt README*
+ dosym ${PN}${PV} /usr/$(get_libdir)/${PN}
+
+ mv "${ED}"/usr/share/man/mann/datefield{,-${PN}}.n || die
+ mv "${ED}"/usr/share/man/mann/menubar{,-${PN}}.n || die
+ mv "${ED}"/usr/bin/dia{,-${PN}} || die
+}