summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-04-20 20:55:47 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-04-20 20:57:49 +0200
commit9ca4779faa8365c5c51a278e6d84d29bb6ab6c01 (patch)
tree7f6772936638fa4a7c5af3b2f08d8ee2dec751c0 /dev-tcltk
parentsys-apps/lssbus: EAPI=8, compile flags fixes, cleanup (diff)
downloadgentoo-9ca4779faa8365c5c51a278e6d84d29bb6ab6c01.tar.gz
gentoo-9ca4779faa8365c5c51a278e6d84d29bb6ab6c01.tar.bz2
gentoo-9ca4779faa8365c5c51a278e6d84d29bb6ab6c01.zip
dev-tcltk/thread: implicit function declarations
Closes: https://bugs.gentoo.org/928059 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-tcltk')
-rw-r--r--dev-tcltk/thread/thread-2.8.5.ebuild4
-rw-r--r--dev-tcltk/thread/thread-2.8.8.ebuild4
-rw-r--r--dev-tcltk/thread/thread-2.8.9.ebuild5
3 files changed, 6 insertions, 7 deletions
diff --git a/dev-tcltk/thread/thread-2.8.5.ebuild b/dev-tcltk/thread/thread-2.8.5.ebuild
index 299354e5ba6b..046cf4206808 100644
--- a/dev-tcltk/thread/thread-2.8.5.ebuild
+++ b/dev-tcltk/thread/thread-2.8.5.ebuild
@@ -11,6 +11,8 @@ DESCRIPTION="Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/project/tcl/Thread%20Extension/${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 ~sparc x86"
@@ -22,8 +24,6 @@ QA_CONFIG_IMPL_DECL_SKIP=(
stat64 # used to test for Large File Support
)
-S="${WORKDIR}"/${MY_P}
-
PATCHES=( "${FILESDIR}"/${P}-musl.patch )
src_prepare() {
diff --git a/dev-tcltk/thread/thread-2.8.8.ebuild b/dev-tcltk/thread/thread-2.8.8.ebuild
index 202ceb1c6cc9..94ce8fc07a35 100644
--- a/dev-tcltk/thread/thread-2.8.8.ebuild
+++ b/dev-tcltk/thread/thread-2.8.8.ebuild
@@ -11,6 +11,8 @@ DESCRIPTION="Tcl Thread extension"
HOMEPAGE="http://www.tcl.tk/"
SRC_URI="mirror://sourceforge/project/tcl/Thread%20Extension/${PV}/${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_P}
+
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
@@ -22,8 +24,6 @@ QA_CONFIG_IMPL_DECL_SKIP=(
opendir64 rewinddir64 closedir64 stat64 # used to test for Large File Support on AIX
)
-S="${WORKDIR}"/${MY_P}
-
PATCHES=( "${FILESDIR}"/${PN}-2.8.5-musl.patch )
src_prepare() {
diff --git a/dev-tcltk/thread/thread-2.8.9.ebuild b/dev-tcltk/thread/thread-2.8.9.ebuild
index ab64d0048cc7..280b7de7c6c5 100644
--- a/dev-tcltk/thread/thread-2.8.9.ebuild
+++ b/dev-tcltk/thread/thread-2.8.9.ebuild
@@ -16,6 +16,7 @@ SRC_URI="
-> tclconfig-2023.12.11.tar.gz
"
+S="${WORKDIR}"/${PN}-${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
@@ -24,11 +25,9 @@ DEPEND="dev-lang/tcl:0=[threads]"
RDEPEND="${DEPEND}"
QA_CONFIG_IMPL_DECL_SKIP=(
- opendir64 rewinddir64 closedir64 stat64 # used to test for Large File Support on AIX
+ opendir64 readdir64 rewinddir64 closedir64 stat64 # used to test for Large File Support on AIX
)
-S="${WORKDIR}"/${PN}-${MY_P}
-
PATCHES=( "${FILESDIR}"/${PN}-2.8.5-musl.patch )
src_prepare() {