summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-02-18 12:01:28 +0100
committerMichał Górny <mgorny@gentoo.org>2017-02-18 12:31:00 +0100
commitf08f73e9dfb4fe3b9cc75fcba125a1ca45ed8a78 (patch)
treecacd56c93309c089dbe9df46e497f41e9a5f0177 /dev-tex
parentdev-tex/crosstex: python-single-r1, EAPI=6 (diff)
downloadgentoo-f08f73e9dfb4fe3b9cc75fcba125a1ca45ed8a78.tar.gz
gentoo-f08f73e9dfb4fe3b9cc75fcba125a1ca45ed8a78.tar.bz2
gentoo-f08f73e9dfb4fe3b9cc75fcba125a1ca45ed8a78.zip
dev-tex/texamator: python-single-r1, EAPI=6
Diffstat (limited to 'dev-tex')
-rw-r--r--dev-tex/texamator/files/texamator3
-rw-r--r--dev-tex/texamator/texamator-1.7.5-r1.ebuild (renamed from dev-tex/texamator/texamator-1.7.5.ebuild)35
2 files changed, 14 insertions, 24 deletions
diff --git a/dev-tex/texamator/files/texamator b/dev-tex/texamator/files/texamator
deleted file mode 100644
index 93e860dc09c1..000000000000
--- a/dev-tex/texamator/files/texamator
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-cd /usr/lib/TeXamator
-exec python2 TeXamator.py
diff --git a/dev-tex/texamator/texamator-1.7.5.ebuild b/dev-tex/texamator/texamator-1.7.5-r1.ebuild
index df0e135ca3c9..94f1c410ffe9 100644
--- a/dev-tex/texamator/texamator-1.7.5.ebuild
+++ b/dev-tex/texamator/texamator-1.7.5-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
-PYTHON_DEPEND="2"
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
-inherit multilib python
+inherit python-single-r1
MY_PN=TeXamator
@@ -19,30 +19,23 @@ KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="app-text/dvipng
- dev-python/PyQt4
+ dev-python/PyQt4[${PYTHON_USEDEP}]
virtual/latex-base"
RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_PN}
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
+src_compile() {
+ cat >> ${PN} <<-_EOF_ || die
+ #!/bin/sh
+ cd /usr/lib/${MY_PN} &&
+ exec "${EPYTHON}" ${MY_PN}.py
+ _EOF_
}
src_install() {
- python_need_rebuild
+ dobin ${PN}
- dobin "${FILESDIR}"/${PN}
-
- insinto /usr/$(get_libdir)/${MY_PN}
- doins -r ${MY_PN}.py partielatormods {ts,ui}_files
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/$(get_libdir)/${MY_PN}
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/${MY_PN}
+ python_moduleinto /usr/lib/${MY_PN}
+ python_domodule ${MY_PN}.py partielatormods {ts,ui}_files
}