summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/aap
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/aap')
-rw-r--r--dev-util/aap/Manifest2
-rw-r--r--dev-util/aap/aap-1.076.ebuild44
-rw-r--r--dev-util/aap/aap-1.091-r2.ebuild42
-rw-r--r--dev-util/aap/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-util/aap/Manifest b/dev-util/aap/Manifest
new file mode 100644
index 000000000000..adc88e239bb7
--- /dev/null
+++ b/dev-util/aap/Manifest
@@ -0,0 +1,2 @@
+DIST aap-1.076.zip 1637913 SHA256 dc223d5e88a25426544bcfeebe4f97a71cfb3aea5fe983956f643d83b6f3841e SHA512 581f34f7bc531e989c725b2e732d47bac57b85b5c738aca3df35279d5979c050277cf9fafffce8bafe304034be1d490abbd089eda2244cf272ad77a61958df11 WHIRLPOOL 52a369f73830c92865ae86b5405ef0e883ef4ff84403e8b4abb086680dd27575e390a5db360aa4e1a6865a14c3e40e844437490d563422fc4a2c45871c98b3ad
+DIST aap-1.091.zip 1645498 SHA256 1cae4e5c6426f3862ef6795e3e1966ef15ab618cde57be2005a0a6c6eac41aae SHA512 37fbbc1d816bfdadf3c4e16a31d002326ce86dbfbdfa60b30785f88aa202e52d79a13c91e7e0e843d93620e5eb9ba50545bc761550386b715359122cd375341e WHIRLPOOL 9b7ec209fe3c86d288037ced9cc5b44b406ed55ccabfada96c1a3423f8eecc91ae50e76f01b07f47d7bb54c0b06f47c7150a3dd5620e71045f3810fc32a857fd
diff --git a/dev-util/aap/aap-1.076.ebuild b/dev-util/aap/aap-1.076.ebuild
new file mode 100644
index 000000000000..d08f1a50a0bc
--- /dev/null
+++ b/dev-util/aap/aap-1.076.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+IUSE="doc"
+
+DESCRIPTION="Bram Moolenaar's super-make program"
+HOMEPAGE="http://www.a-a-p.org/"
+SRC_URI="mirror://sourceforge/a-a-p/${P}.zip"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ia64 ~mips ~ppc sparc x86"
+DEPEND="app-arch/unzip"
+RDEPEND=">=dev-lang/python-1.5"
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ mkdir "${S}" && cd "${S}" && unzip -q "${DISTDIR}"/${A} || die
+}
+
+src_install() {
+ rm doc/*.sgml
+ rm doc/*.pdf
+
+ if use doc ; then
+ dodir /usr/share/doc/${PF}/html
+ cp -R doc/* "${D}"/usr/share/doc/${PF}/html
+ fi
+ rm doc/*.html
+ rm -fr doc/images
+
+ dodoc doc/*
+ doman aap.1
+ rm -rf doc aap.1
+
+ # Move the remainder directly into the dest tree
+ dodir /usr/share
+ cd "${WORKDIR}"
+ mv aap "${D}"/usr/share
+
+ # Create a symbolic link for the executable
+ dodir /usr/bin
+ ln -s ../share/aap/aap "${D}"/usr/bin/aap
+}
diff --git a/dev-util/aap/aap-1.091-r2.ebuild b/dev-util/aap/aap-1.091-r2.ebuild
new file mode 100644
index 000000000000..49089bd00bc3
--- /dev/null
+++ b/dev-util/aap/aap-1.091-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Bram Moolenaar's super-make program"
+HOMEPAGE="http://www.a-a-p.org/"
+SRC_URI="mirror://sourceforge/a-a-p/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+DEPEND="app-arch/unzip"
+RDEPEND="${PYTHON_DEPS}"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S=${WORKDIR}
+
+src_install() {
+ rm doc/*.sgml doc/*.pdf COPYING || die
+ use doc && dohtml -r doc/*.html doc/images
+ rm -r doc/*.html doc/images || die
+
+ dodoc doc/*
+ doman aap.1
+ rm -r doc aap.1 || die
+
+ # Move the remainder directly into the dest tree
+ python_moduleinto /usr/share/aap
+ python_domodule .
+
+ # Create a symbolic link for the executable
+ dosym ../share/aap/aap /usr/bin/aap
+ python_fix_shebang "${ED}"/usr/share/aap/aap
+}
diff --git a/dev-util/aap/metadata.xml b/dev-util/aap/metadata.xml
new file mode 100644
index 000000000000..efa518256292
--- /dev/null
+++ b/dev-util/aap/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="sourceforge">a-a-p</remote-id>
+ </upstream>
+</pkgmetadata>