summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-02-25 14:03:04 -0600
committerWilliam Hubbs <williamh@gentoo.org>2023-02-25 14:05:30 -0600
commit30de76a9e91d56b5fd3409cfb4382c6b317a767c (patch)
tree1f04c444de01723386d4307775a79ae8783d347c /dev-util/gitlab-runner
parentsci-mathematics/dunshire: PEP517 and python-3.11 support. (diff)
downloadgentoo-30de76a9e91d56b5fd3409cfb4382c6b317a767c.tar.gz
gentoo-30de76a9e91d56b5fd3409cfb4382c6b317a767c.tar.bz2
gentoo-30de76a9e91d56b5fd3409cfb4382c6b317a767c.zip
dev-util/gitlab-runner: add 15.8.3, 15.9.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util/gitlab-runner')
-rw-r--r--dev-util/gitlab-runner/Manifest4
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild62
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-15.9.1.ebuild62
3 files changed, 128 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 40bbc1951c3c..8cae0928bdbe 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,7 @@ DIST gitlab-runner-15.7.4-deps.tar.xz 160601896 BLAKE2B a208b751544fec8033276b54
DIST gitlab-runner-15.7.4.tar.bz2 1250425 BLAKE2B 933aa20c9c4ae0008caf0a63e3cc0b8fb22e34830d2536a54980b484913f8e6dc545539697fb36185d0cb1360660a9162fd5231ef4ef351177062b9b2cd56dc5 SHA512 9db90d39e1c52676165f39e9002da777c2e8c4c38c7f9538579628d858e9e541ee1b2e66156c0b6387d503088ea75084dee82a761733366dbd3db895da80a9e5
DIST gitlab-runner-15.8.2-deps.tar.xz 160677404 BLAKE2B 7b1d07dbcbf7ce9255969036f6c29cd2b01d59ff5763f2bb6993def34fc714038c6ace11f2cfbec728396acf93c158d0b350b62340d5795f98e84999c3bf2fed SHA512 9dc6b6e19dc5f203142049e75359ccd31d750803bdee95434436bcc6d9ac2148a92da00598454d5642aafa883e145174bdd3989a525a76db0b1646d0e96c919f
DIST gitlab-runner-15.8.2.tar.bz2 1258847 BLAKE2B be5e704bf12c7c64cab38c8b5a42b03f7023f1e6d390807fbb5b89a650ad07ec1cae2d4f1e7af946e87d33fc6eb14c944912443880ce51b62a944ac8c87e1598 SHA512 3faf5ccd6948511a7f5b31996e860806fe4b15a2b6ee2bf5eb53bc56f52cf4393d20b2a2a93a8741c29a517e8e6b5cb6af3f26d9438aac518a454b300a846557
+DIST gitlab-runner-15.8.3-deps.tar.xz 160672020 BLAKE2B bb0cb16ad7c19afb048c0c1e5d48fc157f25d9a79abc564265152b16e3b436693cc0a0faa02dade584e0b95d9806b491582f8741b2b091798aa6b77a3bf9fadc SHA512 f379f5a514314d6f86fc6ac2dc00b1407e1637709c09555e3828adb7544141224c012cf104e1d47ac67f04c19371536ff338c446c7f69c985e1f67278dbee3c7
+DIST gitlab-runner-15.8.3.tar.bz2 1258834 BLAKE2B 84473b3d704f271e286c7cba696132f2d26ec4d5f4944f99b8ad4dd4accd4f9680b36ca5d13432eaff3ce020b57420b40edccb2620b8e246c2020a2c75fca692 SHA512 4b5d659e257d78d84471fe6799367bc50929e1f0356a8a919d248b490aa73b1fb777086a49f777b5d09b10b649e7829439a1ebd517a83ea7c7ccea8c988676d3
+DIST gitlab-runner-15.9.1-deps.tar.xz 159144912 BLAKE2B f10167c731371dbf4d61a05d9154a3127e286846fd60e2eb7291a587d707389fdb989526942263e7a7fac2af02fc343e316528ee2f64aaf97a048e83e58521f9 SHA512 ae74bbfa62ac4a7506ec6099fab11bcf66f7b270ccc0a17dde0b226cccdbaf51949bea44f437e97c20e4b60c605060b42e77a36a11fb5eb080d55dcf30ee58d5
+DIST gitlab-runner-15.9.1.tar.bz2 1267756 BLAKE2B 1732db4d7d8a3f530654f2897ec665bef87cefbfafc8776ba4b15d327768924d9fef5918a5d31899825e17bba20d04bfd30f6c8cbe834b266cadd0f414cfe840 SHA512 ab82cce1956105046aba8560317e00f3f333669ca7ee305879821bf433485599d2eb206afd8edc04c3b9c3d07eb38dfe335c77ff9a4f431bee5dea0a1d10b9c2
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild
new file mode 100644
index 000000000000..cfcd4b537a95
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.8.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=080abeab
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}
diff --git a/dev-util/gitlab-runner/gitlab-runner-15.9.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-15.9.1.ebuild
new file mode 100644
index 000000000000..9fc00e12c5ee
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-15.9.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=d540b510
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}