summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2022-11-23 13:15:35 +0200
committerViorel Munteanu <ceamac@gentoo.org>2022-11-27 12:07:03 +0200
commite9c538bfdb6c7d4ff996655b9b7cc7b248005b7d (patch)
treeea98636fe7b6c80646378bf58a6d9aaae3357b6c /dev-util/kbuild
parentdev-util/kbuild: fix compilation with clang (diff)
downloadgentoo-e9c538bfdb6c7d4ff996655b9b7cc7b248005b7d.tar.gz
gentoo-e9c538bfdb6c7d4ff996655b9b7cc7b248005b7d.tar.bz2
gentoo-e9c538bfdb6c7d4ff996655b9b7cc7b248005b7d.zip
dev-util/kbuild: drop 0.1.9998.3499-r1, 0.1.9998.3572-r1
Closes: https://github.com/gentoo/gentoo/pull/28399 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'dev-util/kbuild')
-rw-r--r--dev-util/kbuild/kbuild-0.1.9998.3499-r1.ebuild74
-rw-r--r--dev-util/kbuild/kbuild-0.1.9998.3572-r1.ebuild67
2 files changed, 0 insertions, 141 deletions
diff --git a/dev-util/kbuild/kbuild-0.1.9998.3499-r1.ebuild b/dev-util/kbuild/kbuild-0.1.9998.3499-r1.ebuild
deleted file mode 100644
index 26cf9c604e83..000000000000
--- a/dev-util/kbuild/kbuild-0.1.9998.3499-r1.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools toolchain-funcs
-
-MY_P="${P}-src"
-DESCRIPTION="A makefile framework for writing simple makefiles for complex tasks"
-HOMEPAGE="https://trac.netlabs.org/kbuild/wiki"
-#SRC_URI="ftp://ftp.netlabs.org/pub/${PN}/${MY_P}.tar.gz"
-SRC_URI="https://dev.gentoo.org/~polynomial-c/${MY_P}.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-BDEPEND="
- sys-apps/texinfo
- sys-devel/flex
- sys-devel/gettext
- virtual/pkgconfig
- virtual/yacc
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.1.9998.3407-unknown_configure_opt.patch"
- "${FILESDIR}/${PN}-0.1.5-gentoo-docdir.patch"
- "${FILESDIR}/${PN}-0.1.9998_pre20120806-qa.patch"
- "${FILESDIR}/${PN}-0.1.9998_pre20110817-kash-link-pthread.patch"
- "${FILESDIR}/${PN}-0.1.9998.3499-gold.patch"
-
- # Please check on version bumps if this can be removed
- "${FILESDIR}/${PN}-0.1.9998.3499-kash-no_separate_parser_allocator.patch"
-
- "${FILESDIR}/${PN}-0.1.9998.3572-fix-bison.patch"
- "${FILESDIR}/${PN}-0.1.9998.3572-fix-lto.patch"
- "${FILESDIR}/${PN}-0.1.9998.3499-implicit-function-declaration.patch"
-)
-
-pkg_setup() {
- # Package fails with distcc (bug #255371)
- export DISTCC_DISABLE=1
-}
-
-src_prepare() {
- default
-
- # Add a file with the svn revision this package was pulled from
- printf '%s\n' "KBUILD_SVN_REV := $(ver_cut 4)" \
- > SvnInfo.kmk || die
-
- cd "${S}/src/kmk" || die
- eautoreconf
- cd "${S}/src/sed" || die
- eautoreconf
-
- sed -e "s@_LDFLAGS\.$(tc-arch)*.*=@& ${LDFLAGS}@g" \
- -e "s@_CFLAGS\.$(tc-arch)*.*=@& ${CFLAGS}@g" \
- -e "s@_CXXFLAGS\.$(tc-arch)*.*=@& ${CXXFLAGS}@g" \
- -i "${S}"/Config.kmk || die #332225
- tc-export CC PKG_CONFIG RANLIB #AR does not work here
-}
-
-src_compile() {
- kBuild/env.sh --full emake -f bootstrap.gmk AUTORECONF=true AR="$(tc-getAR)" \
- || die "bootstrap failed"
-}
-
-src_install() {
- kBuild/env.sh kmk NIX_INSTALL_DIR=/usr PATH_INS="${D}" install \
- || die "install failed"
-}
diff --git a/dev-util/kbuild/kbuild-0.1.9998.3572-r1.ebuild b/dev-util/kbuild/kbuild-0.1.9998.3572-r1.ebuild
deleted file mode 100644
index 37288f1c0a38..000000000000
--- a/dev-util/kbuild/kbuild-0.1.9998.3572-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools toolchain-funcs
-
-DESCRIPTION="A makefile framework for writing simple makefiles for complex tasks"
-HOMEPAGE="https://trac.netlabs.org/kbuild/wiki"
-SRC_URI="https://dev.gentoo.org/~ceamac/${CATEGORY}/${PN}/${P}-src.tar.xz"
-
-LICENSE="GPL-3+"
-SLOT="0"
-#KEYWORDS="~amd64 ~x86" # for testing only. This version is buggy
-IUSE=""
-
-BDEPEND="
- sys-apps/texinfo
- sys-devel/flex
- sys-devel/gettext
- virtual/pkgconfig
- virtual/yacc
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-0.1.9998.3407-unknown_configure_opt.patch"
- "${FILESDIR}/${PN}-0.1.5-gentoo-docdir.patch"
- "${FILESDIR}/${PN}-0.1.9998_pre20120806-qa.patch"
- "${FILESDIR}/${PN}-0.1.9998_pre20110817-kash-link-pthread.patch"
- "${FILESDIR}/${PN}-0.1.9998.3572-fix-bison.patch"
- "${FILESDIR}/${PN}-0.1.9998.3572-fix-lto.patch"
- "${FILESDIR}/${PN}-0.1.9998.3499-implicit-function-declaration.patch"
-)
-
-pkg_setup() {
- # Package fails with distcc (bug #255371)
- export DISTCC_DISABLE=1
-}
-
-src_prepare() {
- default
-
- # Add a file with the svn revision this package was pulled from
- printf '%s\n' "KBUILD_SVN_REV := $(ver_cut 4)" \
- > SvnInfo.kmk || die
-
- cd "${S}/src/kmk" || die
- eautoreconf
- cd "${S}/src/sed" || die
- eautoreconf
-
- sed -e "s@_LDFLAGS\.$(tc-arch)*.*=@& ${LDFLAGS}@g" \
- -e "s@_CFLAGS\.$(tc-arch)*.*=@& ${CFLAGS}@g" \
- -e "s@_CXXFLAGS\.$(tc-arch)*.*=@& ${CXXFLAGS}@g" \
- -i "${S}"/Config.kmk || die #332225
- tc-export CC PKG_CONFIG RANLIB #AR does not work here
-}
-
-src_compile() {
- kBuild/env.sh --full emake -f bootstrap.gmk AUTORECONF=true AR="$(tc-getAR)" \
- || die "bootstrap failed"
-}
-
-src_install() {
- kBuild/env.sh kmk NIX_INSTALL_DIR=/usr PATH_INS="${D}" install \
- || die "install failed"
-}