summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2016-10-06 11:07:32 +0200
committerMiroslav Šulc <fordfrog@gentoo.org>2016-10-06 11:07:32 +0200
commitce68826d2295ca6f5ff70c7f0767b3fe7036731e (patch)
treee659f60ea59c1ab75adaeb6ab05140f3f933fd1d /dev-util/netbeans
parentprofiles/desc/l10n.desc: reverted my modifications (diff)
downloadgentoo-ce68826d2295ca6f5ff70c7f0767b3fe7036731e.tar.gz
gentoo-ce68826d2295ca6f5ff70c7f0767b3fe7036731e.tar.bz2
gentoo-ce68826d2295ca6f5ff70c7f0767b3fe7036731e.zip
dev-util/netbeans: fixed eapi 6 issue and reverted l10n changes
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-util/netbeans')
-rw-r--r--dev-util/netbeans/netbeans-8.2.ebuild93
1 files changed, 38 insertions, 55 deletions
diff --git a/dev-util/netbeans/netbeans-8.2.ebuild b/dev-util/netbeans/netbeans-8.2.ebuild
index d68b665e948e..c6b49d4d9df9 100644
--- a/dev-util/netbeans/netbeans-8.2.ebuild
+++ b/dev-util/netbeans/netbeans-8.2.ebuild
@@ -13,26 +13,23 @@ PATCHES_URL="http://dev.gentoo.org/~fordfrog/distfiles/netbeans-8.2-build.xml.pa
L10N_URL="http://dev.gentoo.org/~fordfrog/distfiles/netbeans-l10n-8.2-20160920.tar.bz2"
ALL_URLS="${SOURCE_URL} ${PATCHES_URL} ${L10N_URL}"
SRC_URI="l10n_af? ( ${ALL_URLS} )
- l10n_ar-EG? ( ${ALL_URLS} )
- l10n_ar-SA? ( ${ALL_URLS} )
+ l10n_ar? ( ${ALL_URLS} )
l10n_bg? ( ${ALL_URLS} )
l10n_ca? ( ${ALL_URLS} )
l10n_cs? ( ${ALL_URLS} )
l10n_de? ( ${ALL_URLS} )
l10n_el? ( ${ALL_URLS} )
l10n_es? ( ${ALL_URLS} )
- l10n_es-CO? ( ${ALL_URLS} )
- l10n_fil-PH? ( ${ALL_URLS} )
+ l10n_fil? ( ${ALL_URLS} )
l10n_fr? ( ${ALL_URLS} )
- l10n_gl-ES? ( ${ALL_URLS} )
- l10n_hi-IN? ( ${ALL_URLS} )
- l10n_id-ID? ( ${ALL_URLS} )
+ l10n_gl? ( ${ALL_URLS} )
+ l10n_hi? ( ${ALL_URLS} )
+ l10n_id? ( ${ALL_URLS} )
l10n_it? ( ${ALL_URLS} )
l10n_ja? ( ${ALL_URLS} )
l10n_ko? ( ${ALL_URLS} )
l10n_lt? ( ${ALL_URLS} )
- l10n_nl-BE? ( ${ALL_URLS} )
- l10n_nl-NL? ( ${ALL_URLS} )
+ l10n_nl? ( ${ALL_URLS} )
l10n_pl? ( ${ALL_URLS} )
l10n_pt-BR? ( ${ALL_URLS} )
l10n_pt-PT? ( ${ALL_URLS} )
@@ -42,7 +39,7 @@ SRC_URI="l10n_af? ( ${ALL_URLS} )
l10n_sq? ( ${ALL_URLS} )
l10n_sr? ( ${ALL_URLS} )
l10n_sv? ( ${ALL_URLS} )
- l10n_ta-IN? ( ${ALL_URLS} )
+ l10n_ta? ( ${ALL_URLS} )
l10n_tr? ( ${ALL_URLS} )
l10n_vi? ( ${ALL_URLS} )
l10n_zh-CN? ( ${ALL_URLS} )
@@ -68,26 +65,23 @@ IUSE_NETBEANS_MODULES="
+netbeans_modules_websvccommon"
IUSE_L10N="
l10n_af
- l10n_ar-EG
- l10n_ar-SA
+ l10n_ar
l10n_bg
l10n_ca
l10n_cs
l10n_de
l10n_el
l10n_es
- l10n_es-CO
- l10n_fil-PH
+ l10n_fil
l10n_fr
- l10n_gl-ES
- l10n_hi-IN
- l10n_id-ID
+ l10n_gl
+ l10n_hi
+ l10n_id
l10n_it
l10n_ja
l10n_ko
l10n_lt
- l10n_nl-BE
- l10n_nl-NL
+ l10n_nl
l10n_pl
l10n_pt-BR
l10n_pt-PT
@@ -97,7 +91,7 @@ IUSE_L10N="
l10n_sq
l10n_sr
l10n_sv
- l10n_ta-IN
+ l10n_ta
l10n_tr
l10n_vi
l10n_zh-CN
@@ -139,7 +133,14 @@ pkg_setup() {
lang=${lang/-/_}
case ${lang} in
- id-ID) lang="in_ID";;
+ ar) lang="ar_EG,ar_SA" ;;
+ es) lang="es,es_CO" ;;
+ fil) lang="fil_PH" ;;
+ gl) lang="gl_ES" ;;
+ hi) lang="hi_IN" ;;
+ id) lang="in_ID" ;;
+ nl) lang="nl_BE,nl_NL" ;;
+ ta) lang="ta_IN" ;;
esac
if [ -z "${NBLOCALES}" ] ; then
@@ -172,24 +173,12 @@ src_prepare() {
epatch netbeans-8.2-build.xml.patch
- # Support for custom patches
- if [ -n "${NETBEANS9999_PATCHES_DIR}" -a -d "${NETBEANS9999_PATCHES_DIR}" ] ; then
- local files=`find "${NETBEANS9999_PATCHES_DIR}" -type f`
-
- if [ -n "${files}" ] ; then
- einfo "Applying custom patches:"
-
- for file in ${files} ; do
- epatch "${file}"
- done
- fi
- fi
-
einfo "Symlinking external libraries..."
java-pkg_jar-from --build-only --into javahelp/external javahelp jhall.jar jhall-2.0_05.jar
fi
java-pkg-2_src_prepare
+ default
}
src_compile() {
@@ -223,30 +212,24 @@ src_install() {
for lingua in ${IUSE_L10N}; do
if use ${lingua} ; then
- local locale=${lingua/l10n_/}
- locale=${locale/-/:}
-
- case ${locale} in
- id:ID) lang="in:ID";;
+ local locales=${lingua/l10n_/}
+ locales=${locales/-/:}
+
+ case ${locales} in
+ ar) lang="ar:EG ar:SA" ;;
+ es) lang="es es:CO" ;;
+ fil) lang="fil:PH" ;;
+ gl) lang="gl:ES" ;;
+ hi) lang="hi:IN" ;;
+ id) lang="in:ID" ;;
+ nl) lang="nl:BE nl:NL" ;;
+ ta) lang="ta:IN" ;;
esac
- make_desktop_entry "netbeans-${SLOT} --locale ${locale}" "Netbeans ${PV} ${locale}" netbeans-${SLOT} Development
+ for locale in ${locales}; do
+ make_desktop_entry "netbeans-${SLOT} --locale ${locale}" "Netbeans ${PV} ${locale}" netbeans-${SLOT} Development
+ done
fi
done
fi
}
-
-pkg_postinst() {
- if [ -n "${NBLOCALES}" ] ; then
- einfo "Netbeans automatically starts with the locale you have set in your user profile, if"
- einfo "the locale is built for Netbeans."
- einfo "If you want to force specific locale, use --locale argument, for example:"
- einfo "${PN}-${SLOT} --locale de"
- einfo "${PN}-${SLOT} --locale pt:BR"
- fi
-
- if use l10n_id_ID ; then
- einfo
- einfo "You selected Indonesian locale which has locale code in:ID in Netbeans."
- fi
-}