summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Molik <dan@danmolik.com>2019-01-05 07:01:08 -0500
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-06 14:46:20 -0800
commit70311e8fba3a14b5e5680970a6ceff9424603323 (patch)
treed1a206d67822cc06aafa4c4ece5f405325249e43 /dev-util/packer/packer-1.3.3.ebuild
parentapp-arch/tar: arm64 stable (bug #674210) (diff)
downloadgentoo-70311e8fba3a14b5e5680970a6ceff9424603323.tar.gz
gentoo-70311e8fba3a14b5e5680970a6ceff9424603323.tar.bz2
gentoo-70311e8fba3a14b5e5680970a6ceff9424603323.zip
dev-util/packer: new package
Adding Hashicorp's packer utility to better support automated image building. One can find documentation here: https://packer.io and find the code base here: https://github.com/hashicorp/packer Closes: https://github.com/gentoo/gentoo/pull/10744 Closes: https://bugs.gentoo.org/624472 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Dan Molik <dan@danmolik.com> Tested-by: Dan Molik <dan@danmolik.com> Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-util/packer/packer-1.3.3.ebuild')
-rw-r--r--dev-util/packer/packer-1.3.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-util/packer/packer-1.3.3.ebuild b/dev-util/packer/packer-1.3.3.ebuild
new file mode 100644
index 000000000000..8cae3f47d007
--- /dev/null
+++ b/dev-util/packer/packer-1.3.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit golang-vcs-snapshot
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+
+EGO_PN="github.com/hashicorp/packer"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+DEPEND=">=dev-lang/go-1.11.0"
+
+DOCS="README.md CHANGELOG.md"
+
+src_compile() {
+ cd "src/${EGO_PN}" || die
+ GOPATH="${S}" GOCACHE="${T}/go-cache" go build \
+ -v -work -o "${S}/${PN}" ./ || die
+}
+
+src_install() {
+ dobin packer
+
+ pushd "src/${EGO_PN}" || die
+ einstalldocs
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+ popd || die
+}