summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcos Rodrigues Gonzalez <neutroniak@gmail.com>2024-06-11 22:38:12 -0300
committerArthur Zamarin <arthurzam@gentoo.org>2024-06-13 17:39:08 +0300
commitfeb121b017d135e90611292773859e0d17825745 (patch)
tree7044a7e04690cd2b718dc151c27b83e7a4e7faba /dev-util/packer
parentdev-util/conan: add 2.4.1 (diff)
downloadgentoo-feb121b017d135e90611292773859e0d17825745.tar.gz
gentoo-feb121b017d135e90611292773859e0d17825745.tar.bz2
gentoo-feb121b017d135e90611292773859e0d17825745.zip
dev-util/packer: add 1.11.0
Signed-off-by: Marcos Rodrigues Gonzalez <neutroniak@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/37126 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util/packer')
-rw-r--r--dev-util/packer/Manifest2
-rw-r--r--dev-util/packer/packer-1.11.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/packer/Manifest b/dev-util/packer/Manifest
index 5991d6cba8bb..6e5c6af3b327 100644
--- a/dev-util/packer/Manifest
+++ b/dev-util/packer/Manifest
@@ -1,2 +1,4 @@
+DIST packer-1.11.0-deps.tar.xz 274685472 BLAKE2B 211e076e5032c5199597bda8d05a4f13d15db321d78f58ac3e5775f8ba16b0bd7dd348a396bb6bed41c039924d288e5ea6abd5a140558f25d1edbc75d39c4ba0 SHA512 200d2aa56b834202bd3b1506991f6ea4686e95345fed09eea923fbf00577d8ac2454cfd567c89926b9e99f777203b3ee908c30a4d9f7e71f2370061f09d53603
+DIST packer-1.11.0.tar.gz 2296683 BLAKE2B 8b8eee2294109d305b94186829995f881d1b8a1a0db4a57e117e4473705f3a8e7e589ec7bb3d7efa10acbecc967623404902aeecdcd1474e266bc9c43410604c SHA512 304dbacfaf59fcc35876754f6a6766cc89e052b64970f42aa315c1141f349d6437538195512dc8cd7626d467faaf0bd68575cc8310f9fc8e7606faabd7cf748d
DIST packer-1.9.5-deps.tar.xz 373922748 BLAKE2B 793b0e5501bca56849a2471fbe2892c4775c3aa2d3ad6346e65f3d0cf1e3d86339a64371a35e4fddb0053082e98e2ec527b4f052b901bf8d35bd5db08a577ee4 SHA512 1f49b45841308dba95fcce2139d21931708e099102cc0870be00f2142cfb0d0e8ce9e2c729c9556ca68c1036e224f120fe0cd8833715a62cc212eead2448a6e3
DIST packer-1.9.5.tar.gz 2302965 BLAKE2B dc0b8fedd83a477594c7235ffe6ca2052ba389e105bd451ad6c3987cea68c37f9c3153957012339f2a09045f20ac81ff6a59ed33834247408a3539643d9ecedf SHA512 7df1a85d0746e400c42f2b2a52b14ef5a806bcd2dc346eceaf5f8928b42a8b046ff8da7b45e5af0486bd444d8325e1cabdcd15f7b28711241a46034c9781a279
diff --git a/dev-util/packer/packer-1.11.0.ebuild b/dev-util/packer/packer-1.11.0.ebuild
new file mode 100644
index 000000000000..cbf0fffdc750
--- /dev/null
+++ b/dev-util/packer/packer-1.11.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+DESCRIPTION="A tool to create identical machine images for multiple platforms"
+HOMEPAGE="https://www.packer.io"
+SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://gentoo.neutroniak.com/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 BSD-4 MIT MPL-2.0 unicode Unicode-DFS-2016 ISC BUSL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv"
+
+DOCS=( {README,CHANGELOG}.md )
+
+RESTRICT+=" test"
+
+src_compile() {
+ ego build \
+ -mod=readonly \
+ -ldflags "${go_ldflags}" \
+ -work -o "bin/${PN}" ./ || die
+}
+
+src_install() {
+ dobin bin/packer
+
+ einstalldocs
+
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh-completion/_packer
+}