summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/patchelf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/Manifest1
-rw-r--r--dev-util/patchelf/files/patchelf-0.8-dash.patch28
-rw-r--r--dev-util/patchelf/metadata.xml7
-rw-r--r--dev-util/patchelf/patchelf-0.8.ebuild37
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-util/patchelf/Manifest b/dev-util/patchelf/Manifest
new file mode 100644
index 000000000000..bf2ff6e432be
--- /dev/null
+++ b/dev-util/patchelf/Manifest
@@ -0,0 +1 @@
+DIST patchelf-0.8.tar.bz2 119369 SHA256 c99f84d124347340c36707089ec8f70530abd56e7827c54d506eb4cc097a17e7 SHA512 819ace0ee032612e8bef56f230ea470be9d44bc03ef561f98ffac84f2555e419f87309280df6d265a8ae56452e54d46fc90be13a449847e93e4e7b413dc8605a WHIRLPOOL 64c56eda439dc114e4450428d7bde754a894ecbd8d2e0d1a29c3a53965527f76723fef9a240cd3686532f9202c84b23dd25cfe8e4f664ac33e08ca4056ef6780
diff --git a/dev-util/patchelf/files/patchelf-0.8-dash.patch b/dev-util/patchelf/files/patchelf-0.8-dash.patch
new file mode 100644
index 000000000000..4210b1c054d0
--- /dev/null
+++ b/dev-util/patchelf/files/patchelf-0.8-dash.patch
@@ -0,0 +1,28 @@
+From 3b9e7913a6d14cb09ed91ce8a1110955bda200ef Mon Sep 17 00:00:00 2001
+From: Alexandre Pretyman <alexandre.pretyman@gmail.com>
+Date: Tue, 14 Jul 2015 09:12:38 -0400
+Subject: [PATCH] Change configure.ac from OpenWrt to support Mac OS
+
+This change is from the OpenWrt project, from the URL:
+https://dev.openwrt.org/ticket/18998
+It enables patchelf to sucessfully compile and run under Mac OS and
+keeps compatibility with Linux.
+
+Tested under Mac OS X 10.9.5 and Ubuntu 15.04 to patch a binary of type
+ELF 32-bit LSB executable - the patch fully worked
+
+This patch is credited to Felix Fietkau
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 8ca9ad4..69e12de 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1,4 +1,4 @@
+-AC_INIT([patchelf], m4_esyscmd([echo -n $(cat ./version)]))
++AC_INIT([patchelf], m4_esyscmd([printf $(cat ./version)]))
+ AC_CONFIG_SRCDIR([src/patchelf.cc])
+ AC_CONFIG_AUX_DIR([build-aux])
+ AM_INIT_AUTOMAKE([-Wall -Werror dist-bzip2 foreign color-tests parallel-tests])
diff --git a/dev-util/patchelf/metadata.xml b/dev-util/patchelf/metadata.xml
new file mode 100644
index 000000000000..4a00a64b40ae
--- /dev/null
+++ b/dev-util/patchelf/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/dev-util/patchelf/patchelf-0.8.ebuild b/dev-util/patchelf/patchelf-0.8.ebuild
new file mode 100644
index 000000000000..ef8f82a7d792
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.8.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="http://nixos.org/patchelf.html"
+SRC_URI="http://releases.nixos.org/${PN}/${P}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE=""
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=( "${FILESDIR}"/${P}-dash.patch )
+
+src_prepare() {
+ rm src/elf.h || die
+ sed -e 's:-Werror::g' -i configure.ac || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( --docdir="${EPREFIX}"/usr/share/doc/${PF} )
+ autotools-utils_src_configure
+}
+
+src_test() {
+ autotools-utils_src_test -j1
+}