summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-06 03:28:47 +0000
committerSam James <sam@gentoo.org>2021-03-06 03:28:47 +0000
commitafc149b0a711d09ad70cbc65dc463b12f2c9ba1a (patch)
tree314bd8089f9822806a9a58a2856b892e71b6da53 /dev-util/pkgcheck
parentdev-python/cython: rebase multiprocessing Darwin patch for 0.29.22 (diff)
downloadgentoo-afc149b0a711d09ad70cbc65dc463b12f2c9ba1a.tar.gz
gentoo-afc149b0a711d09ad70cbc65dc463b12f2c9ba1a.tar.bz2
gentoo-afc149b0a711d09ad70cbc65dc463b12f2c9ba1a.zip
dev-util/pkgcheck: add upper bound on dev-python/tree-sitter
To avoid errors like: ValueError: Incompatible Language version 11. Must be between 13 and 13 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/pkgcheck')
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.8.1-r1.ebuild (renamed from dev-util/pkgcheck/pkgcheck-0.8.1.ebuild)2
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.8.2-r1.ebuild (renamed from dev-util/pkgcheck/pkgcheck-0.8.2.ebuild)2
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.9.0-r1.ebuild (renamed from dev-util/pkgcheck/pkgcheck-0.9.0.ebuild)2
-rw-r--r--dev-util/pkgcheck/pkgcheck-0.9.1-r1.ebuild (renamed from dev-util/pkgcheck/pkgcheck-0.9.1.ebuild)2
4 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/pkgcheck/pkgcheck-0.8.1.ebuild b/dev-util/pkgcheck/pkgcheck-0.8.1-r1.ebuild
index a768d08fe5a5..d625f9d99b44 100644
--- a/dev-util/pkgcheck/pkgcheck-0.8.1.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-0.8.1-r1.ebuild
@@ -33,7 +33,7 @@ RDEPEND+="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
- dev-python/tree-sitter[${PYTHON_USEDEP}]
+ <dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
diff --git a/dev-util/pkgcheck/pkgcheck-0.8.2.ebuild b/dev-util/pkgcheck/pkgcheck-0.8.2-r1.ebuild
index 7f4f92b3664a..8d94a5810da8 100644
--- a/dev-util/pkgcheck/pkgcheck-0.8.2.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-0.8.2-r1.ebuild
@@ -33,7 +33,7 @@ RDEPEND+="
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
- dev-python/tree-sitter[${PYTHON_USEDEP}]
+ <dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
diff --git a/dev-util/pkgcheck/pkgcheck-0.9.0.ebuild b/dev-util/pkgcheck/pkgcheck-0.9.0-r1.ebuild
index b119c84b2823..01cc542dcbc7 100644
--- a/dev-util/pkgcheck/pkgcheck-0.9.0.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-0.9.0-r1.ebuild
@@ -34,7 +34,7 @@ RDEPEND+="
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
- dev-python/tree-sitter[${PYTHON_USEDEP}]
+ <dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
diff --git a/dev-util/pkgcheck/pkgcheck-0.9.1.ebuild b/dev-util/pkgcheck/pkgcheck-0.9.1-r1.ebuild
index 7bf477d198f4..f4fc9d8e1d48 100644
--- a/dev-util/pkgcheck/pkgcheck-0.9.1.ebuild
+++ b/dev-util/pkgcheck/pkgcheck-0.9.1-r1.ebuild
@@ -34,7 +34,7 @@ RDEPEND+="
dev-python/lazy-object-proxy[${PYTHON_USEDEP}]
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pathspec[${PYTHON_USEDEP}]
- dev-python/tree-sitter[${PYTHON_USEDEP}]
+ <dev-python/tree-sitter-0.19.0[${PYTHON_USEDEP}]
"
BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )