summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-21 21:56:48 +0000
committerSam James <sam@gentoo.org>2023-01-21 21:57:36 +0000
commitc1075fa68084d855b738c052790b5cbe7f5520c8 (patch)
tree492e43e9a1b96ff05828c8b45b06326366a63660 /dev-util/watchman/files
parentdev-cpp/edencommon: add 2023.01.16.00 (diff)
downloadgentoo-c1075fa68084d855b738c052790b5cbe7f5520c8.tar.gz
gentoo-c1075fa68084d855b738c052790b5cbe7f5520c8.tar.bz2
gentoo-c1075fa68084d855b738c052790b5cbe7f5520c8.zip
dev-util/watchman: add 2023.01.16.00
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/watchman/files')
-rw-r--r--dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch10
-rw-r--r--dev-util/watchman/files/watchman-2023.01.16.00-python-working-dir.patch73
2 files changed, 83 insertions, 0 deletions
diff --git a/dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch b/dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch
new file mode 100644
index 000000000000..170450f43f69
--- /dev/null
+++ b/dev-util/watchman/files/watchman-2023.01.16.00-gcc13.patch
@@ -0,0 +1,10 @@
+--- a/watchman/Errors.h
++++ b/watchman/Errors.h
+@@ -8,6 +8,7 @@
+ #pragma once
+
+ #include <fmt/core.h>
++#include <cstdint>
+ #include <string>
+ #include <system_error>
+
diff --git a/dev-util/watchman/files/watchman-2023.01.16.00-python-working-dir.patch b/dev-util/watchman/files/watchman-2023.01.16.00-python-working-dir.patch
new file mode 100644
index 000000000000..bdda035482cd
--- /dev/null
+++ b/dev-util/watchman/files/watchman-2023.01.16.00-python-working-dir.patch
@@ -0,0 +1,73 @@
+--- a/watchman/python/setup.py
++++ b/watchman/python/setup.py
+@@ -13,30 +13,10 @@ try:
+ except ImportError:
+ from distutils.core import Extension, setup
+
+-watchman_src_dir = os.environ.get("CMAKE_CURRENT_SOURCE_DIR")
+-if watchman_src_dir is None:
+- watchman_src_dir = os.path.join(os.path.dirname(os.path.realpath(__file__)), "..")
+-
+-# Setuptools is very picky about the path on Windows. They have to be relative
+-# paths, and on Windows that means we have to be on the same drive as the source
+-# files. Otherwise it is impossible to obtain a relative path across different
+-# drives. However this has an implication that we will not be able to build this
+-# package outside the repository. Not great but it works.
+-py_dir = os.path.join(watchman_src_dir, "watchman", "python")
+-if os.name == "nt":
+- os.chdir(py_dir)
+- py_dir = os.path.relpath(py_dir)
+-
+-
+-def srcs(names):
+- """transform a list of sources to be relative to py_dir"""
+- return ["%s/%s" % (py_dir, n) for n in names]
+-
+
+ setup(
+ name="pywatchman",
+ version="1.4.1",
+- package_dir={"": py_dir},
+ description="Watchman client for python",
+ author="Wez Furlong, Rain",
+ author_email="wez@fb.com",
+@@ -50,7 +30,7 @@ setup(
+ ext_modules=[
+ Extension(
+ "pywatchman.bser",
+- sources=srcs(["pywatchman/bsermodule.c", "pywatchman/bser.c"]),
++ sources=["pywatchman/bsermodule.c", "pywatchman/bser.c"],
+ )
+ ],
+ platforms="Platform Independent",
+@@ -68,12 +48,10 @@ setup(
+ "Programming Language :: Python :: 3.6",
+ ],
+ zip_safe=True,
+- scripts=srcs(
+- [
++ scripts=[
+ "bin/watchman-make",
+ "bin/watchman-wait",
+ "bin/watchman-replicate-subscription",
+- ]
+- ),
++ ],
+ test_suite="tests",
+ )
+--- a/watchman/python/tests/tests.py
++++ b/watchman/python/tests/tests.py
+@@ -28,13 +28,6 @@ from pywatchman import (
+ )
+
+
+-if os.path.basename(bser.__file__) == "pybser.py":
+- raise Exception(
+- "bser module resolved to pybser! Something is broken in your build. __file__={!r}, sys.path={!r}".format(
+- bser.__file__, sys.path
+- )
+- )
+-
+ PILE_OF_POO = "\U0001F4A9"
+ NON_UTF8_STRING = b"\xff\xff\xff"
+