summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz@gentoo.org>2024-11-14 12:08:03 -0500
committerEli Schwartz <eschwartz@gentoo.org>2024-11-17 23:14:08 -0500
commit8c707a5d6acdf250a5eb8b452ce514069c6127b3 (patch)
treee5450528f51d1f133bae347029005306d78cf4b8 /dev-util
parentnet-proxy/dante: version bump (diff)
downloadgentoo-8c707a5d6acdf250a5eb8b452ce514069c6127b3.tar.gz
gentoo-8c707a5d6acdf250a5eb8b452ce514069c6127b3.tar.bz2
gentoo-8c707a5d6acdf250a5eb8b452ce514069c6127b3.zip
dev-util/diff-cover: further work on testsuite
Various missing test dependencies, backported patch to make test fixtures match output for modern versions of lint tools being checked against. Bug: https://github.com/gentoo/gentoo/pull/39262 Signed-off-by: Eli Schwartz <eschwartz@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/diff-cover/Manifest1
-rw-r--r--dev-util/diff-cover/diff-cover-6.5.0-r2.ebuild14
2 files changed, 14 insertions, 1 deletions
diff --git a/dev-util/diff-cover/Manifest b/dev-util/diff-cover/Manifest
index f461ce668b53..90948e9f831a 100644
--- a/dev-util/diff-cover/Manifest
+++ b/dev-util/diff-cover/Manifest
@@ -1 +1,2 @@
+DIST diff-cover-6.5.0-testfixtures.patch 18608 BLAKE2B d298ca1b756ef7fce4a449c4b84fd5508496f13006e11d93af791b20f47a8039e7a3d7ac2c400577f7816db14b4c84f6aacf361f3d3c57d02278d36f3cc40236 SHA512 3a3041edcbca00a336cbe5b3b8c4aa648a0b70bbcd190349968610d0dc6115da0e5e258fe14de6f73c975d9adf72955126ef9266fd16f82db6d1d683095c64b9
DIST diff-cover-6.5.0.tar.gz 108392 BLAKE2B fc3a2a46e66501da5c08ce58fc13e46671246737320a0b6350b78f6b777d3759ec47d4ada170bb3dffcfe0927920741a3c5bff03509d92b2cc873cecce282eb1 SHA512 a00a1009fc8b9ca46f93573e3a2d6eb6a6a29f0e61891c839209dbe3d208d873a42524b30e3a18918817d173cefc3c5f481f7eea689170d72b5cd08857a8f021
diff --git a/dev-util/diff-cover/diff-cover-6.5.0-r2.ebuild b/dev-util/diff-cover/diff-cover-6.5.0-r2.ebuild
index c7342ba66d61..71e57f3a2beb 100644
--- a/dev-util/diff-cover/diff-cover-6.5.0-r2.ebuild
+++ b/dev-util/diff-cover/diff-cover-6.5.0-r2.ebuild
@@ -8,7 +8,10 @@ inherit distutils-r1
DESCRIPTION="Find diff lines that do not have test coverage"
HOMEPAGE="https://github.com/Bachmann1234/diff-cover"
-SRC_URI="https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI="
+ https://github.com/Bachmann1234/diff-cover/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/Bachmann1234/diff_cover/commit/bd39c1c410721aac5a73e38d8f989df0261cdbb6.patch?full_index=1
+ -> ${P}-testfixtures.patch"
S="${WORKDIR}/${P/diff-cover/diff_cover}"
LICENSE="Apache-2.0"
@@ -22,10 +25,19 @@ RDEPEND="
>=dev-python/chardet-3.0.0[${PYTHON_USEDEP}]
>=dev-python/tomli-1.2.1[${PYTHON_USEDEP}]
"
+# Note: flake8/pylint called as shell tools, not imported libraries
BDEPEND="
test? (
+ dev-python/flake8
+ dev-python/pylint
+ dev-python/pytest-datadir[${PYTHON_USEDEP}]
dev-python/pytest-mock[${PYTHON_USEDEP}]
)
"
+PATCHES=(
+ # updated test fixtures for newer versions of code analysis tools
+ "${DISTDIR}/${P}-testfixtures.patch"
+)
+
distutils_enable_tests pytest