summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-10-23 10:24:18 +0200
committerMichał Górny <mgorny@gentoo.org>2024-10-23 10:24:28 +0200
commitbd2feb1c4b7c44f7aff5e658e89fbe4daeb84c30 (patch)
tree10f741ec77795c53db4a542b4cbcf4c3b590c542 /dev-util
parentdev-python/pypy3_9-exe: Remove last-rited pkg (diff)
downloadgentoo-bd2feb1c4b7c44f7aff5e658e89fbe4daeb84c30.tar.gz
gentoo-bd2feb1c4b7c44f7aff5e658e89fbe4daeb84c30.tar.bz2
gentoo-bd2feb1c4b7c44f7aff5e658e89fbe4daeb84c30.zip
dev-util/biew: Remove last-rited pkg
Bug: https://bugs.gentoo.org/874732 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/biew/Manifest1
-rw-r--r--dev-util/biew/biew-6.1.0-r3.ebuild66
-rw-r--r--dev-util/biew/files/biew-610-crash.patch28
-rw-r--r--dev-util/biew/files/biew-610-fix_localedep-1.patch26
-rw-r--r--dev-util/biew/files/biew-610-portable_configure-1.patch167
-rw-r--r--dev-util/biew/metadata.xml8
6 files changed, 0 insertions, 296 deletions
diff --git a/dev-util/biew/Manifest b/dev-util/biew/Manifest
deleted file mode 100644
index 34f131bc1e1b..000000000000
--- a/dev-util/biew/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST biew-610-src.tar.bz2 860517 BLAKE2B 23ccb5e17dc3d99c6eeb303ad26a9779faa5a648208e0a7291b7f120f492db80f0995449ca2e6982de73543cbc7d9210c3f56077eeffceef46e4ea17cb838b5a SHA512 df8d3c10c30e30db1bc5fdba73601a148f7a1480e69a3d03a02ec303534f37db9c5a9eb7ac087d8f1d8cc64d4a0f6e11548c5b385e132e3a981a6f328e3b5742
diff --git a/dev-util/biew/biew-6.1.0-r3.ebuild b/dev-util/biew/biew-6.1.0-r3.ebuild
deleted file mode 100644
index 6bebd8f70bbc..000000000000
--- a/dev-util/biew/biew-6.1.0-r3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-MY_P=${PN}-$(ver_rs 1- "")
-
-DESCRIPTION="A portable viewer of binary files, hexadecimal and disassembler modes"
-HOMEPAGE="http://beye.sourceforge.net/"
-SRC_URI="https://downloads.sourceforge.net/beye/${PV}/${MY_P}-src.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="gpm cpu_flags_x86_mmx cpu_flags_x86_sse"
-REQUIRED_USE="cpu_flags_x86_mmx cpu_flags_x86_sse"
-
-RDEPEND="gpm? ( sys-libs/gpm )"
-DEPEND="${RDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-610-fix_localedep-1.patch
- "${FILESDIR}"/${PN}-610-portable_configure-1.patch
- "${FILESDIR}"/${PN}-610-crash.patch
-)
-
-src_prepare() {
- default
- sed -i -e 's^man/man1/biew.1^share/man/man1/biew.1^' makefile || die
-}
-
-src_configure() {
- append-flags -mmmx -msse #362043
- append-cppflags $(usex gpm -DHAVE_MOUSE -UHAVE_MOUSE)
-
- ./configure \
- --datadir="${EPREFIX}"/usr/share/${PN} \
- --prefix="${EPREFIX}"/usr \
- --cc="$(tc-getCC)" \
- --ld="$(tc-getCC)" \
- --ar="$(tc-getAR) -rcu" \
- --as="$(tc-getAS)" \
- --ranlib="$(tc-getRANLIB)" || die "configure failed"
-}
-
-src_compile() {
- emake LDFLAGS="${LDFLAGS}"
-}
-
-src_install() {
- default
- dodoc doc/{biew_en,release,unix}.txt
-}
-
-pkg_postinst() {
- elog
- elog "Note: if you are upgrading from <=dev-util/biew-6.1.0 you will need"
- elog "to change the paths in the setup dialog (F9) from /usr/share/ to"
- elog "/usr/share/biew/ Alternatively, you can delete ~/.biewrc and it will"
- elog "automatically determine the correct locations on the next run."
- elog
-}
diff --git a/dev-util/biew/files/biew-610-crash.patch b/dev-util/biew/files/biew-610-crash.patch
deleted file mode 100644
index 244f94a7ad53..000000000000
--- a/dev-util/biew/files/biew-610-crash.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-If .biewrc does not exist, the setup dialog appears at program start. If you try
-to click a checkbox with the mouse, biew tries to dereference a null pointer
-(because the MainWindow is not yet set).
-
-This patch adds a workaround. Note that you actually cannot click a checkbox.
-But that is what users might expect. (Maybe the biew code should be changed to
-handle this properly.) Well, it is better not to crash, even if the checkboxes
-are not clickable.
-
- –nico
-
-
-diff -Naur biew-610.orig/events.c biew-610/events.c
---- biew-610.orig/events.c 2009-09-03 16:57:40.000000000 +0000
-+++ biew-610/events.c 2011-09-06 09:41:01.000000000 +0000
-@@ -118,7 +118,11 @@
- }
- else
- {
-- X1 = 0; X2 = twGetClientWidth(MainWnd); Y1 = 1; Y2 = twGetClientHeight(MainWnd) - 1;
-+ TWindow *wnd =
-+ MainWnd ? MainWnd : /*XXX:drop this line?*/
-+ twGetWinAtPos(mx, my);
-+ if(!wnd) return KE_MOUSE;
-+ X1 = 0; X2 = twGetClientWidth(wnd); Y1 = 1; Y2 = twGetClientHeight(wnd) - 1;
- }
- wdh = X2 - X1;
- hght = Y2 - Y1;
diff --git a/dev-util/biew/files/biew-610-fix_localedep-1.patch b/dev-util/biew/files/biew-610-fix_localedep-1.patch
deleted file mode 100644
index babe994e070a..000000000000
--- a/dev-util/biew/files/biew-610-fix_localedep-1.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-The configure script of biew-6.1.0 fails with
- Checking for C compiler name ... gcc-Version
-if using the de_DE.UTF-8 locale and sys-devel/gcc-4.5.2. It may fail with other
-locales and/or compilers, too. The problem occurs due to the fact that the
-string “gcc version” written by gcc for ‘gcc -v’ is translated according to the
-language (German in the case mentioned above).
-
-This patch makes sure that the POSIX locale is used when the biew configure
-script checks for the name of the compiler. This allows the configure script to
-parse the output properly.
-
- –nico
-
-
-diff -Naur biew-610.orig/configure biew-610/configure
---- biew-610.orig/configure 2009-11-13 15:52:36.000000000 +0100
-+++ biew-610/configure 2011-01-13 11:11:59.000000000 +0100
-@@ -497,7 +497,7 @@
-
- _cdefos="-DDATADIR='\"$_datadir\"'"
-
--cc_name=`$_cc -v 2>&1 | tail -n 1 | cut -d ' ' -f 1`
-+cc_name=`LC_ALL=POSIX $_cc -v 2>&1 | tail -n 1 | cut -d ' ' -f 1`
- cc_version=`$_cc -dumpversion`
-
- echocheck "C compiler name"
diff --git a/dev-util/biew/files/biew-610-portable_configure-1.patch b/dev-util/biew/files/biew-610-portable_configure-1.patch
deleted file mode 100644
index c64f6280ba08..000000000000
--- a/dev-util/biew/files/biew-610-portable_configure-1.patch
+++ /dev/null
@@ -1,167 +0,0 @@
-Changes the biew-610 configure script to use portable test constructs. See the
-Autoconf manual <URL:https://www.gnu.org/software/autoconf/manual/html_node/
-Limitations-of-Builtins.html#index-g_t_0040command_007btest_007d-1725> for
-explanations.
-
- –nico
-
-
-diff -Naur biew-610.orig/configure biew-610/configure
---- biew-610.orig/configure 2009-11-13 14:52:36.000000000 +0000
-+++ biew-610/configure 2011-02-24 09:44:10.000000000 +0000
-@@ -171,7 +171,7 @@
- # 1st: print out help
-
- for parm in "$@" ; do
-- if test "$parm" = "--help" || test "$parm" = "-help" || test "$parm" = "-h" ; then
-+ if test "X$parm" = "X--help" || test "X$parm" = "X-help" || test "X$parm" = "X-h" ; then
- cat << EOF
-
- Usage: $0 [OPTIONS]...
-@@ -235,7 +235,7 @@
- _cp=cp
- _libext=a
- _libprefix=lib
--test "$CC" && _cc="$CC"
-+test "X$CC" != X && _cc="$CC"
- _prefix="/usr/local"
- _datadir=
- _libdir=
-@@ -340,11 +340,11 @@
- ;;
- esac
- done
--test -z "$_datadir" && _datadir=$_prefix"/share/biew"
--test -z "$_libdir" && _libdir=$_prefix"/lib/biew"
-+test "X$_datadir" = X && _datadir=$_prefix"/share/biew"
-+test "X$_libdir" = X && _libdir=$_prefix"/lib/biew"
-
- for I in "$TMPDIR" "$TEMPDIR" "/tmp" ; do
-- test "$I" && break
-+ test "X$I" != X && break
- done
-
- TMPLOG="config.log"
-@@ -357,8 +357,8 @@
- _tee="tee -a $TMPLOG"
-
- echocheck "architecture"
--if test "$_target_arch" = auto ; then
-- if test -z "$host_arch" ; then
-+if test "X$_target_arch" = Xauto ; then
-+ if test "X$host_arch" = X ; then
- host_arch=`( uname -p ) 2>&1`
- log "uname -p :" "$host_arch"
- case "$host_arch" in
-@@ -416,8 +416,8 @@
- x86_64 && _bitness=64
-
- echocheck "target OS"
--if test "$_target_system" = auto ; then
-- if test -z "$system_name" ; then
-+if test "X$_target_system" = Xauto ; then
-+ if test "X$system_name" = X ; then
- # OS name
- system_name=`uname -s`
- log "uname -s :" "$system_name"
-@@ -461,8 +461,8 @@
- fi
- fi
-
--if test "$_target_system" = auto ; then
-- if test -z "$system_name" ; then
-+if test "X$_target_system" = Xauto ; then
-+ if test "X$system_name" = X ; then
- # OS name
- system_name=`/bin/sh --version 2>&1 | sed -n 's/^.*\([(]\)./\1/p'`
- log "/bin/sh --version:" "$system_name"
-@@ -549,7 +549,7 @@
- ;;
- esac
-
--if test -z "$_x11incdir" ; then
-+if test "X$_x11incdir" = X ; then
- echocheck "X11 headers"
- for I in /usr/include /usr/X11R6/include /usr/X11/include /usr/openwin/include ; do
- if test -d "$I/X11" ; then
-@@ -559,11 +559,11 @@
- fi
- done
- fi
--if test -z "$_x11incdir" ; then
-+if test "X$_x11incdir" = X ; then
- echores "x11inc not found"
- fi
-
--if test -z "$_x11libdir" ; then
-+if test "X$_x11libdir" = X ; then
- echocheck "X11 libs"
- for I in /usr/X11R6/lib /usr/X11/lib /usr/lib32 /usr/openwin/lib ; do
- if test -d "$I" ; then
-@@ -573,24 +573,24 @@
- fi
- done
- fi
--if test -z "$_x11libdir" ; then
-+if test "X$_x11libdir" = X ; then
- echores "x11lib not found"
- fi
-
--test -z "$_debug" && _osldef="-s $_osldef" || _cdefos="-finline-limit-5 $_cdefos"
--if test "$_profile" -o "$_debug" -o "$_gcov"; then
-+test "X$_debug" = X && _osldef="-s $_osldef" || _cdefos="-finline-limit-5 $_cdefos"
-+if test "X$_profile" != X || test "X$_debug" != X || test "X$_gcov" != X ; then
- _cdefos="-W -Wall -O2 -fno-builtin $_debug $_profile $_gcov $_cdefos"
- _osldef="$_debug $_profile $_osldef"
--elif test -z "$CFLAGS" ; then
-+elif test "X$CFLAGS" = X ; then
- _cdefos="-DNDEBUG=1 -O2 -ffast-math -fomit-frame-pointer $_cdefos"
- x86 && _cdefos="-mmmx -msse $_cdefos"
- else
- _cdefos="-DNDEBUG=1 $CFLAGS $_cdefos"
- fi
--test -n "$LDFLAGS" && _osldef="$LDFLAGS $_osldef"
--test -n "$LIBS" && _osldef="$LIBS $_osldef"
-+test "X$LDFLAGS" != X && _osldef="$LDFLAGS $_osldef"
-+test "X$LIBS" != X && _osldef="$LIBS $_osldef"
-
--if test "$_target_system" = dos ; then
-+if test "X$_target_system" = Xdos ; then
- # disable cc_check call for DJGPP due bugs in bash
- _cdefos="-D__HAVE_PRAGMA_PACK__=1 $_cdefos"
- else
-@@ -668,10 +668,10 @@
- _curseslib=
- disable _curses
- cc_check -lcurses && _curseslib="-lcurses"
-- if test -z "$_curseslib" ; then
-+ if test "X$_curseslib" = X ; then
- cc_check -lncurses && _curseslib="-lncurses"
- fi
-- if test -n "$_curseslib" ; then
-+ if test "X$_curseslib" != X ; then
- enable _curses
- _cdefos="-D_CURSES_ -D__OS_NAME__='\"Unix/Curses\"' $_cdefos"
- _oslibs="$_curseslib $_oslibs"
-@@ -711,10 +711,10 @@
- enabled sys_resource_h && _cdefos="-DHAVE_SYS_RESOURCE=1 $_cdefos"
- echores "$sys_resource_h"
-
--if test -z "$_x11libdir" ; then
-+if test "X$_x11libdir" = X ; then
- _cdefos="$_cdefos"
- else
-- if test -z "$_x11incdir" ; then
-+ if test "X$_x11incdir" = X ; then
- _cdefos="$_cdefos"
- else
- _cdefos="-DHAVE_X11 $_cdefos"
-@@ -738,7 +738,7 @@
- fi
-
- # Checking for INSTALL
--if test -z $_install
-+if test "X$_install" = X
- then
- _install="install"
- $_install --version 1>/dev/null 2>/dev/null || _install=""
diff --git a/dev-util/biew/metadata.xml b/dev-util/biew/metadata.xml
deleted file mode 100644
index 20ac9642b774..000000000000
--- a/dev-util/biew/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="sourceforge">beye</remote-id>
- </upstream>
-</pkgmetadata>