summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-17 21:13:51 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-18 15:27:43 +0100
commitc30bb98cbe94491397a2af7d1dc4332bf436b4e2 (patch)
treef8c928825b6a60e1eee6ac400dcf5b76b9948d47 /dev-util
parentMove {dev-util → dev-debug}/pwndbg (diff)
downloadgentoo-c30bb98cbe94491397a2af7d1dc4332bf436b4e2.tar.gz
gentoo-c30bb98cbe94491397a2af7d1dc4332bf436b4e2.tar.bz2
gentoo-c30bb98cbe94491397a2af7d1dc4332bf436b4e2.zip
Move {dev-util → dev-debug}/gef
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gef/Manifest2
-rw-r--r--dev-util/gef/gef-2023.08.ebuild82
-rw-r--r--dev-util/gef/gef-2024.01.ebuild83
-rw-r--r--dev-util/gef/gef-9999.ebuild83
-rw-r--r--dev-util/gef/metadata.xml24
5 files changed, 0 insertions, 274 deletions
diff --git a/dev-util/gef/Manifest b/dev-util/gef/Manifest
deleted file mode 100644
index ba2a872e5a3b..000000000000
--- a/dev-util/gef/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST gef-2023.08.tar.gz 230347 BLAKE2B b9b8fed1bdf81fa870583921c4bdd6df2d98112748c939da48acae7e636ec6e22dc751d8ed75e52e72ff0aa04835720293f0e82e99ff614c447f2a614c76e48a SHA512 d3a26826b991db7e8d475da945b16933ce046dd64381f5df60ea0fe310d0325f39b05142de5f75abbbd5693c93ad70ff25e982d0ff3526a6fe66fd7526a359c5
-DIST gef-2024.01.tar.gz 235145 BLAKE2B f5409e592c50dbbe65761e7727f28aa7a96b130449f187e392cc0170707b7cfb2d1bf9e75581dce7dce8ff6d004ffc624d34a46b7ba35ab434a5671662860bdb SHA512 d8dbc308f864e434ea79eaf44e329e11f2cea9836a5dcdc019bd621bbec6792f70e58edd9fd8b3c434dc61a17fbac08394e281530423081beb1cc1192aece79c
diff --git a/dev-util/gef/gef-2023.08.ebuild b/dev-util/gef/gef-2023.08.ebuild
deleted file mode 100644
index dcf8e73117bf..000000000000
--- a/dev-util/gef/gef-2023.08.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="
- dev-python/mkdocs-material
-"
-
-inherit python-single-r1 docs wrapper
-
-DESCRIPTION="GDB Enhanced Features for exploit devs & reversers"
-HOMEPAGE="https://github.com/hugsy/gef"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hugsy/gef"
-else
- SRC_URI="https://github.com/hugsy/gef/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~ppc ~ppc64 x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-# Seem to hang right now?
-RESTRICT="!test? ( test ) test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
- dev-util/ropper[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-libs/capstone[python,${PYTHON_USEDEP}]
- dev-libs/keystone[python,${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-util/unicorn[python,${PYTHON_USEDEP}]
- ')"
-
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- ')
- )"
-
-DOCS=( README.md )
-
-src_prepare() {
- default
-
- sed -i -e '/pylint/d' tests/requirements.txt || die
-}
-
-src_compile() {
- # Tries to compile tests
- :
-
- docs_compile
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r *.py
-
- python_optimize "${ED}/usr/share/${PN}"
-
- make_wrapper "gdb-gef" \
- "gdb -x \"/usr/share/${PN}/gef.py\"" || die
-
- einstalldocs
-}
-
-pkg_postinst() {
- einfo "\nUsage:"
- einfo " ~$ gdb-gef <program>\n"
-}
diff --git a/dev-util/gef/gef-2024.01.ebuild b/dev-util/gef/gef-2024.01.ebuild
deleted file mode 100644
index ab3ad1835c9a..000000000000
--- a/dev-util/gef/gef-2024.01.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="
- dev-python/mkdocs-material
-"
-
-inherit python-single-r1 docs wrapper
-
-DESCRIPTION="GDB Enhanced Features for exploit devs & reversers"
-HOMEPAGE="https://github.com/hugsy/gef"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hugsy/gef"
-else
- SRC_URI="https://github.com/hugsy/gef/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-# Seem to hang right now?
-RESTRICT="!test? ( test ) test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-util/ropper[${PYTHON_SINGLE_USEDEP}]
- dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-libs/capstone[python,${PYTHON_USEDEP}]
- dev-libs/keystone[python,${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/rpyc[${PYTHON_USEDEP}]
- dev-util/unicorn[python,${PYTHON_USEDEP}]
- ')"
-
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- ')
- )"
-
-DOCS=( README.md )
-
-src_prepare() {
- default
-
- sed -i -e '/pylint/d' tests/requirements.txt || die
-}
-
-src_compile() {
- # Tries to compile tests
- :
-
- docs_compile
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r *.py
-
- python_optimize "${ED}/usr/share/${PN}"
-
- make_wrapper "gdb-gef" \
- "gdb -x \"/usr/share/${PN}/gef.py\"" || die
-
- einstalldocs
-}
-
-pkg_postinst() {
- einfo "\nUsage:"
- einfo " ~$ gdb-gef <program>\n"
-}
diff --git a/dev-util/gef/gef-9999.ebuild b/dev-util/gef/gef-9999.ebuild
deleted file mode 100644
index b692b6cc9ec0..000000000000
--- a/dev-util/gef/gef-9999.ebuild
+++ /dev/null
@@ -1,83 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{10..12} )
-
-DOCS_BUILDER="mkdocs"
-DOCS_DEPEND="
- dev-python/mkdocs-material
-"
-
-inherit python-single-r1 docs wrapper
-
-DESCRIPTION="GDB Enhanced Features for exploit devs & reversers"
-HOMEPAGE="https://github.com/hugsy/gef"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/hugsy/gef"
-else
- SRC_URI="https://github.com/hugsy/gef/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~arm64 ~x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-IUSE="test"
-# Seem to hang right now?
-RESTRICT="!test? ( test ) test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ${PYTHON_DEPS}
- dev-debug/gdb[python,${PYTHON_SINGLE_USEDEP}]
- dev-util/ropper[${PYTHON_SINGLE_USEDEP}]
- $(python_gen_cond_dep '
- dev-libs/capstone[python,${PYTHON_USEDEP}]
- dev-libs/keystone[python,${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/rpyc[${PYTHON_USEDEP}]
- dev-util/unicorn[python,${PYTHON_USEDEP}]
- ')"
-
-BDEPEND="
- test? (
- $(python_gen_cond_dep '
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- ')
- )"
-
-DOCS=( README.md )
-
-src_prepare() {
- default
-
- sed -i -e '/pylint/d' tests/requirements.txt || die
-}
-
-src_compile() {
- # Tries to compile tests
- :
-
- docs_compile
-}
-
-src_install() {
- insinto "/usr/share/${PN}"
- doins -r *.py
-
- python_optimize "${ED}/usr/share/${PN}"
-
- make_wrapper "gdb-gef" \
- "gdb -x \"/usr/share/${PN}/gef.py\"" || die
-
- einstalldocs
-}
-
-pkg_postinst() {
- einfo "\nUsage:"
- einfo " ~$ gdb-gef <program>\n"
-}
diff --git a/dev-util/gef/metadata.xml b/dev-util/gef/metadata.xml
deleted file mode 100644
index 9ee6bdf0edc1..000000000000
--- a/dev-util/gef/metadata.xml
+++ /dev/null
@@ -1,24 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="person" proxied="yes">
- <email>mario.haustein@hrz.tu-chemnitz.de</email>
- <name>Mario Haustein</name>
- </maintainer>
- <maintainer type="person">
- <email>sam@gentoo.org</email>
- <name>Sam James</name>
- </maintainer>
- <longdescription>
- GEF is a set of commands for x86/64, ARM, MIPS, PowerPC and SPARC to
- assist exploit developers and reverse-engineers when using old school
- GDB. It provides additional features to GDB using the Python API to
- assist during the process of dynamic analysis and exploit development.
- Application developers will also benefit from it, as GEF lifts a great
- part of regular GDB obscurity, avoiding repeating traditional commands,
- or bringing out the relevant information from the debugging runtime.
- </longdescription>
- <upstream>
- <remote-id type="github">hugsy/gef</remote-id>
- </upstream>
-</pkgmetadata>