summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/gitsh
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/gitsh')
-rw-r--r--dev-vcs/gitsh/Manifest1
-rw-r--r--dev-vcs/gitsh/gitsh-0.8.ebuild50
-rw-r--r--dev-vcs/gitsh/metadata.xml10
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-vcs/gitsh/Manifest b/dev-vcs/gitsh/Manifest
new file mode 100644
index 000000000000..8fc5c7da426e
--- /dev/null
+++ b/dev-vcs/gitsh/Manifest
@@ -0,0 +1 @@
+DIST gitsh-0.8.tar.gz 48393 SHA256 61125105819f8b10005ed41ed334ab2ad6104a8dba799090b0827b72075b1665 SHA512 9ec115f0e71e3708245b11cef0c853446b2e774c30372b5516a239e9db03937d9cde1d1525ca1812759b5c3d59101179490691756a84478ebd8667268beeb8ae WHIRLPOOL 9b0368091ffe59191eff481073b9fa06172d39f2a14076ff03866767349daf0fb3e1de62d7d176bd88efefaceecf68eec607b0ec72a86b1709c8ae9f71f3a96e
diff --git a/dev-vcs/gitsh/gitsh-0.8.ebuild b/dev-vcs/gitsh/gitsh-0.8.ebuild
new file mode 100644
index 000000000000..4e18b0440029
--- /dev/null
+++ b/dev-vcs/gitsh/gitsh-0.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit autotools ruby-fakegem
+
+DESCRIPTION="An interactive shell for git"
+HOMEPAGE="https://github.com/thoughtbot/gitsh"
+SRC_URI="https://github.com/thoughtbot/gitsh/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~amd64-linux"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/bundler
+ dev-ruby/blankslate:2
+ dev-ruby/metaclass
+ dev-ruby/bourne
+ dev-ruby/coderay
+ dev-ruby/diff-lcs
+ dev-ruby/method_source
+ dev-ruby/mocha:0.14
+ dev-ruby/parslet
+ dev-ruby/pry
+ dev-ruby/slop:3
+ dev-ruby/rspec:2
+ "
+
+DOCS="README.md"
+
+each_ruby_prepare() {
+ rm Gemfile.lock || die
+ eautoreconf
+}
+
+each_ruby_configure() {
+ default
+}
+
+each_ruby_compile() {
+ default
+}
diff --git a/dev-vcs/gitsh/metadata.xml b/dev-vcs/gitsh/metadata.xml
new file mode 100644
index 000000000000..f89100e407ee
--- /dev/null
+++ b/dev-vcs/gitsh/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">thoughtbot/gitsh</remote-id>
+ </upstream>
+</pkgmetadata>