summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-vcs/kdesvn
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-vcs/kdesvn')
-rw-r--r--dev-vcs/kdesvn/Manifest1
-rw-r--r--dev-vcs/kdesvn/files/kdesvn-1.6.0-bug-address.patch20
-rw-r--r--dev-vcs/kdesvn/kdesvn-1.6.0-r1.ebuild42
-rw-r--r--dev-vcs/kdesvn/metadata.xml10
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-vcs/kdesvn/Manifest b/dev-vcs/kdesvn/Manifest
new file mode 100644
index 000000000000..951567136e96
--- /dev/null
+++ b/dev-vcs/kdesvn/Manifest
@@ -0,0 +1 @@
+DIST kdesvn-1.6.0.tar.bz2 1863823 SHA256 05686f246b76810f90a9f80f1d45cdccf812b42e18fa10a16b14e7d27d370f96 SHA512 e8ac9a55a8003e5cf724fc49281355fa0b6926ed2c984cece3f3fa076bac03ad1e9f1ab0e258d91e547f8cb542a739e0933e57f64bc0b9fa06417a4bcc5ae8cd WHIRLPOOL 13921530f77db3b4b30a7cfef86468d9c4f94d900017b3747f81114b83c0dbc22a84cb63c76cefe51ef5a6823e0c8ceac31de77bc8279897b679608ea4c2b43f
diff --git a/dev-vcs/kdesvn/files/kdesvn-1.6.0-bug-address.patch b/dev-vcs/kdesvn/files/kdesvn-1.6.0-bug-address.patch
new file mode 100644
index 000000000000..e1c9907bb59f
--- /dev/null
+++ b/dev-vcs/kdesvn/files/kdesvn-1.6.0-bug-address.patch
@@ -0,0 +1,20 @@
+--- src/main.cpp.old 2013-07-07 17:37:05.617114521 +0200
++++ src/main.cpp 2013-07-07 17:37:20.322929644 +0200
+@@ -40,7 +40,6 @@
+ KAboutData::License_GPL,ki18n("(C) 2005-2009 Rajko Albrecht"));
+ about.addAuthor( ki18n("Rajko Albrecht"),ki18n("Developer"),QByteArray("ral@alwins-world.de"),QByteArray());
+ about.setHomepage("http://kdesvn.alwins-world.de/");
+- about.setBugAddress("kdesvn-bugs@alwins-world.de");
+
+ KCmdLineArgs::init(argc, argv, &about);
+ KCmdLineOptions options;
+--- src/kdesvn_part.cpp.old 2013-07-07 17:37:41.415664472 +0200
++++ src/kdesvn_part.cpp 2013-07-07 17:37:53.484512746 +0200
+@@ -174,7 +174,6 @@
+ about.addAuthor(ki18n("Rajko Albrecht"), ki18n("Original author and maintainer"), "ral@alwins-world.de" );
+ about.setOtherText(m_Extratext);
+ about.setHomepage("http://kdesvn.alwins-world.de/");
+- about.setBugAddress("kdesvn-bugs@alwins-world.de");
+ about.setProgramIconName("kdesvn");
+ about.setTranslator(ki18n("kdesvn: NAME OF TRANSLATORS\\nYour names"),
+ ki18n("kdesvn: EMAIL OF TRANSLATORS\\nYour emails"));
diff --git a/dev-vcs/kdesvn/kdesvn-1.6.0-r1.ebuild b/dev-vcs/kdesvn/kdesvn-1.6.0-r1.ebuild
new file mode 100644
index 000000000000..af14991902a8
--- /dev/null
+++ b/dev-vcs/kdesvn/kdesvn-1.6.0-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KDE_LINGUAS="cs de el es fr it ja lt pt_BR ro ru"
+KDE_LINGUAS_LIVE_OVERRIDE="true"
+inherit flag-o-matic kde4-base
+
+DESCRIPTION="KDESvn is a frontend to the subversion vcs"
+HOMEPAGE="http://kdesvn.alwins-world.de/"
+if [[ ${PV} != 9999* ]]; then
+ SRC_URI="http://kdesvn.alwins-world.de/downloads/${P}.tar.bz2"
+fi
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86"
+SLOT="4"
+IUSE="debug"
+
+DEPEND="
+ dev-libs/apr:1
+ dev-libs/apr-util:1
+ >=dev-vcs/subversion-1.7
+ sys-devel/gettext
+ dev-qt/qtsql:4[sqlite]
+"
+RDEPEND="${DEPEND}
+ !kde-apps/kdesdk-kioslaves:4[subversion(+)]
+"
+
+PATCHES=( "${FILESDIR}/${P}-bug-address.patch" )
+
+src_configure() {
+ append-cppflags -DQT_THREAD_SUPPORT
+
+ [[ ${PV} = 9999* ]] && mycmakeargs=(-DDAILY_BUILD=ON)
+
+ kde4-base_src_configure
+}
diff --git a/dev-vcs/kdesvn/metadata.xml b/dev-vcs/kdesvn/metadata.xml
new file mode 100644
index 000000000000..aae019204ec7
--- /dev/null
+++ b/dev-vcs/kdesvn/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>dev-tools</herd>
+ <herd>kde</herd>
+ <maintainer>
+ <email>george@gentoo.org</email>
+ <name>George Shapovalov</name>
+ </maintainer>
+</pkgmetadata>