summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-12-13 10:54:55 +0000
committerMarek Szuba <marecki@gentoo.org>2022-12-13 10:54:55 +0000
commit2402bd56e409fbb6b0c40ed7e2fe7354a8a602a6 (patch)
tree71d1a85f495d1cf50296f108ffb640cffaa75936 /dev-vcs/pre-commit
parentapp-admin/ansible-lint: deselect more network-dependent tests (diff)
downloadgentoo-2402bd56e409fbb6b0c40ed7e2fe7354a8a602a6.tar.gz
gentoo-2402bd56e409fbb6b0c40ed7e2fe7354a8a602a6.tar.bz2
gentoo-2402bd56e409fbb6b0c40ed7e2fe7354a8a602a6.zip
dev-vcs/pre-commit: require non-multicall coreutils for tests
Two of the parse_shebang_test.py tests do not like it it where echo is a wrapper around the multicall binary. Given the behaviour demonstrated by pre-commit upstream, I don't really them to address this any time soon. Closes: https://bugs.gentoo.org/885559 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'dev-vcs/pre-commit')
-rw-r--r--dev-vcs/pre-commit/pre-commit-2.20.0-r1.ebuild2
1 files changed, 2 insertions, 0 deletions
diff --git a/dev-vcs/pre-commit/pre-commit-2.20.0-r1.ebuild b/dev-vcs/pre-commit/pre-commit-2.20.0-r1.ebuild
index 193a7222eaaa..ca37f6d9c248 100644
--- a/dev-vcs/pre-commit/pre-commit-2.20.0-r1.ebuild
+++ b/dev-vcs/pre-commit/pre-commit-2.20.0-r1.ebuild
@@ -26,11 +26,13 @@ RDEPEND="dev-vcs/git
>=dev-python/pyyaml-5.1[${PYTHON_USEDEP}]
>=dev-python/virtualenv-20.0.8[${PYTHON_USEDEP}]
')"
+# coreutils requirement: see Bug #885559
BDEPEND="test? (
$(python_gen_cond_dep '
dev-python/pytest-env[${PYTHON_USEDEP}]
dev-python/re-assert[${PYTHON_USEDEP}]
')
+ sys-apps/coreutils[-multicall]
)"
PATCHES=(