summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-08-25 23:03:15 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-08-25 23:03:15 -0700
commit6f6351833107ff717b0d8717672c27079b2697c2 (patch)
treee82d137296a32768d62c46fac114b20c7348a749 /dev-vcs/tig
parentmedia-sound/strawberry: Stabilize 1.0.7 x86, #866590 (diff)
downloadgentoo-6f6351833107ff717b0d8717672c27079b2697c2.tar.gz
gentoo-6f6351833107ff717b0d8717672c27079b2697c2.tar.bz2
gentoo-6f6351833107ff717b0d8717672c27079b2697c2.zip
dev-vcs/tig: add 2.5.7
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/Manifest1
-rw-r--r--dev-vcs/tig/tig-2.5.7.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-vcs/tig/Manifest b/dev-vcs/tig/Manifest
index 3b6da3c15916..a16b08f9cb40 100644
--- a/dev-vcs/tig/Manifest
+++ b/dev-vcs/tig/Manifest
@@ -1,2 +1,3 @@
DIST tig-2.5.5.tar.gz 1175752 BLAKE2B c77ff0990e5984df6a247cddb1729532719617178fb89143f1f78817f686cb357bc80678e8a1c245c338a40c20c69473b554d8af83381386821358495ed26f29 SHA512 63f617dfcbd89de715573caa92ca83906cefa6a5229876f1d5390b4b58442b0bec958065b798d4e81729dc87bf6dcd2a392fbbab2cd66ca16df6e2e9d6362ca3
DIST tig-2.5.6.tar.gz 1176006 BLAKE2B eda766b32022fd6d849048107d9de90cb668ac594db1f46ee94984a5487f1a01c3109e3279c2c9e2260ef04ad7687b8c5eeb52ecf0b5e9d5c4b1f649aa23d46f SHA512 4d55061db43d64be9c97589d37305f6dcd85f1e7381012a9d61d21226dad456a86b16401fffe7763808dab62f07e17b2bcd17b9a30e1349e252be85f479e3741
+DIST tig-2.5.7.tar.gz 1176146 BLAKE2B e67847741469a776f5cfb9c7f51fd651c81ed2c03e4627e708481eca3a47dfdebb3ef1d827cccb01ec0b5de7514bfe4b6e9e5dcfc1d39469d21eb6297e4c3086 SHA512 26adbb8dc43ef7ec1eaf5d6def29a8b6dcf5e30825242fc489208139c8720805a265dd1ba412601df692f6d0438ee9e3171a3f8a3cc4599841d82dfc08a9ea1f
diff --git a/dev-vcs/tig/tig-2.5.7.ebuild b/dev-vcs/tig/tig-2.5.7.ebuild
new file mode 100644
index 000000000000..656ca0a2e20b
--- /dev/null
+++ b/dev-vcs/tig/tig-2.5.7.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="pcre test unicode"
+REQUIRED_USE="test? ( unicode )"
+
+DEPEND="
+ sys-libs/ncurses:=[unicode(+)?]
+ sys-libs/readline:0=
+ pcre? ( dev-libs/libpcre2:= )
+"
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"
+[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc app-text/xmlto"
+
+# encoding/env issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with pcre) \
+ $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ LC_ALL=en_US.utf8 emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ docinto examples
+ dodoc contrib/*.tigrc
+}