summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2021-06-04 07:09:04 +0300
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-06-03 22:04:48 -0700
commitf1c78501029dd7b977e43e76b85a038ebdf03a6b (patch)
treed0041bf01391288b1674df99e795e0c75b305287 /dev-vcs/tig
parentdev-lang/typescript: initial import (diff)
downloadgentoo-f1c78501029dd7b977e43e76b85a038ebdf03a6b.tar.gz
gentoo-f1c78501029dd7b977e43e76b85a038ebdf03a6b.tar.bz2
gentoo-f1c78501029dd7b977e43e76b85a038ebdf03a6b.zip
dev-vcs/tig: do not install tig-completion.zsh
tig-completion.zsh (installed as /usr/share/zsh/site-functions/_tig) doesn't work and interferes with '_git' from app-shell/zsh, which already adds comletion for tig. Don't install the file to make completion for tig in zsh work. Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Stefan Strogin <steils@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/21116 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'dev-vcs/tig')
-rw-r--r--dev-vcs/tig/tig-2.5.3-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/dev-vcs/tig/tig-2.5.3-r1.ebuild b/dev-vcs/tig/tig-2.5.3-r1.ebuild
new file mode 100644
index 000000000000..9164067a481e
--- /dev/null
+++ b/dev-vcs/tig/tig-2.5.3-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jonas/tig.git"
+ inherit git-r3 autotools
+else
+ SRC_URI="https://github.com/jonas/tig/releases/download/${P}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+DESCRIPTION="text mode interface for git"
+HOMEPAGE="https://jonas.github.io/tig/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="test unicode"
+REQUIRED_USE="test? ( unicode )"
+
+DEPEND="
+ sys-libs/ncurses:0=[unicode?]
+ sys-libs/readline:0=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-vcs/git
+"
+[[ ${PV} == "9999" ]] && BDEPEND+=" app-text/asciidoc app-text/xmlto"
+
+# encoding/env issues
+RESTRICT="test"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ econf $(use_with unicode ncursesw)
+}
+
+src_compile() {
+ emake V=1
+ [[ ${PV} == "9999" ]] && emake V=1 doc-man doc-html
+}
+
+src_test() {
+ # workaround parallel test failures
+ emake -j1 test
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-doc-man
+ dodoc doc/manual.html README.html NEWS.html
+ newbashcomp contrib/tig-completion.bash ${PN}
+
+ dodoc contrib/*.tigrc
+}