summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-10-02 20:01:43 +0200
committerSebastian Pipping <sping@gentoo.org>2023-10-02 20:04:15 +0200
commit3e3b23d4ffadc54d3e9db24c6be784d857a30282 (patch)
tree3c74e77af2b7efa2d10f9104cdf588b3f98af040 /dev-vcs
parentapp-doc/python-docs: Bump to 3.12.0 (diff)
downloadgentoo-3e3b23d4ffadc54d3e9db24c6be784d857a30282.tar.gz
gentoo-3e3b23d4ffadc54d3e9db24c6be784d857a30282.tar.bz2
gentoo-3e3b23d4ffadc54d3e9db24c6be784d857a30282.zip
dev-vcs/rsvndump: 0.6.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/rsvndump/Manifest1
-rw-r--r--dev-vcs/rsvndump/rsvndump-0.6.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-vcs/rsvndump/Manifest b/dev-vcs/rsvndump/Manifest
index 0257d0fd4937..cfed37a13b52 100644
--- a/dev-vcs/rsvndump/Manifest
+++ b/dev-vcs/rsvndump/Manifest
@@ -1,2 +1,3 @@
DIST rsvndump-0.6.1.tar.bz2 233503 BLAKE2B eee3c0c61724544bc5b335d97eb76b0826cadaa883830f84e9be6fab4f901121d0cb2517633b5a53f2bc465d5ce384ce234d052860eadfd7c5237ac0192ab771 SHA512 3055070b8e128dad0ef099130d3ac7fe147a334b97c3db71354f37a00dfba3ec34194bf4dc5f1e31315852681501422986ac3d6b032fa4d6a6f9d87c45c5b391
+DIST rsvndump-0.6.2.tar.bz2 234950 BLAKE2B 8c42ca253573df0fdadac28ae19602c02fbf156c0cdc136607191c666498707610929d0c535f743c9a7f978ef0b2e42da33c696abc7ed377fc486d01a1e11830 SHA512 a33d262c9a5e6c82129fa11fc503439d903e7237275e7fd14ab728c1d4c37496bcc7a5b59e3dd937df7108ccf0b24078635771b6297c1337912d6eda396cd406
DIST rsvndump-0.6.tar.bz2 220891 BLAKE2B 97792a13beb0a37452df941599a753297f0322d04608e86da0740cb553a9da7d1a2f9b6e712c15698ae9d5f2c8d4911d8bed45e66c58ca46b2d1b0c29ec4f275 SHA512 cadb10b48e66be1ea562fa6b96460b5c864e2f16a1e0d5fbb4be4d31023b6d5dfa978634900b1649530a12335eb712032d9d9cc82f663737581521121d3b2120
diff --git a/dev-vcs/rsvndump/rsvndump-0.6.2.ebuild b/dev-vcs/rsvndump/rsvndump-0.6.2.ebuild
new file mode 100644
index 000000000000..f59d8cbbc67b
--- /dev/null
+++ b/dev-vcs/rsvndump/rsvndump-0.6.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Dump a remote Subversion repository"
+HOMEPAGE="http://rsvndump.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3+ BSD public-domain" # rsvndump, snappy-c, critbit89
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-vcs/subversion
+ dev-libs/apr
+ dev-libs/apr-util
+ sys-devel/gettext"
+DEPEND="${RDEPEND}
+ doc? ( app-text/xmlto
+ >=app-text/asciidoc-8.4 )"
+
+src_prepare() {
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/739028).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ if [[ $(get_libdir) != lib ]] ; then
+ grep -wq svn_prefix/lib m4/find_svn.m4 || die
+ sed "s,svn_prefix/lib,svn_prefix/$(get_libdir)," -i m4/find_svn.m4 || die
+ grep -w svn_prefix/lib m4/find_svn.m4 && die
+
+ grep -wq SVN_PREFIX/lib configure.ac || die
+ sed "s,SVN_PREFIX/lib,SVN_PREFIX/$(get_libdir)," -i configure.ac || die
+ grep -w SVN_PREFIX/lib configure.ac && die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable doc man) \
+ $(use_enable debug)
+}